summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-18 17:19:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-18 17:20:27 +0200
commitbe528eb53d6c5c6d3ef7d74a02da2e2b97c0ccc6 (patch)
treebe3106290db787ec7582c377c9c2f2b54a7799bf
parentcbdac3ce88d97dac03a26bccc6e25df35b332086 (diff)
downloadguix-patches-be528eb53d6c5c6d3ef7d74a02da2e2b97c0ccc6.tar
guix-patches-be528eb53d6c5c6d3ef7d74a02da2e2b97c0ccc6.tar.gz
gnu: hunspell-dict-en & variants: Make reproducible.
* gnu/packages/aspell.scm (aspell-word-list)[arguments]: Add a new 'make-reproducible phase. Fixes <http://issues.guix.gnu.org/48499>.
-rw-r--r--gnu/packages/aspell.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index e5241c4e46..e19c369517 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -397,6 +397,10 @@ dictionaries, including personal ones.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ (substitute* "speller/README_en.txt.sh"
+ (("\\bdate\\b") ""))))
(delete 'configure)
(delete 'check)
(replace 'build