summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-06 21:53:32 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 22:02:15 +0200
commitb949f34f31a045eb0fb242b81a223178fb6994d3 (patch)
tree837a94d9d642039f46ce071b8ac1adbb805b3a71
parent3dc8052b51241fe7857059d3300dad3a0f9f68fd (diff)
downloadguix-patches-b949f34f31a045eb0fb242b81a223178fb6994d3.tar
guix-patches-b949f34f31a045eb0fb242b81a223178fb6994d3.tar.gz
gnu: Use the non-deprecated TeX packages.
This commit leaves 'dblatex' and 'texlive-hyperref' as users of deprecated packages, but these have many dependents. * gnu/packages/bioinformatics.scm (discrover)[native-inputs]: Use non-deprecated TeX Live packages. (velvet)[native-inputs]: Likewise. * gnu/packages/chez.scm (chez-scheme)[native-inputs]: Likewise. (chez-web)[native-inputs]: Likewise. * gnu/packages/engineering.scm (fastcap)[native-inputs]: Likewise. * gnu/packages/guile-xyz.scm (emacsy)[native-inputs]: Likewise. * gnu/packages/maths.scm (hypre)[native-inputs]: Likewise. * gnu/packages/music.scm (lilypond)[native-inputs]: Likewise. * gnu/packages/ocaml.scm (ocaml-bibtex2html)[native-inputs]: Likewise. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]: Likewise. (python-matplotlib-documentation)[native-inputs]: Likewise. (python-ipython-documentation)[native-inputs]: Likewise. (python-nbconvert)[native-inputs]: Likewise. (python-pypandoc)[native-inputs]: Likewise. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Likewise. * gnu/packages/tex.scm (texlive-pstool)[propagated-inputs]: Likewise. (teximpatient)[native-inputs]: Likewise. (texlive-latex-pgf)[propagated-inputs]: Likewise. (texlive-beamer)[propagated-inputs]: Likewise.
-rw-r--r--gnu/packages/bioinformatics.scm6
-rw-r--r--gnu/packages/chez.scm10
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/guile-xyz.scm2
-rw-r--r--gnu/packages/maths.scm4
-rw-r--r--gnu/packages/music.scm2
-rw-r--r--gnu/packages/ocaml.scm2
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/python-xyz.scm42
-rw-r--r--gnu/packages/statistics.scm6
-rw-r--r--gnu/packages/tex.scm14
11 files changed, 46 insertions, 46 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0718b5e31c..430551887d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3110,9 +3110,9 @@ data and settings.")
`(("texlive" ,(texlive-updmap.cfg (list texlive-cm
texlive-amsfonts
- texlive-latex-doi
+ texlive-doi
texlive-latex-examplep
- texlive-latex-hyperref
+ texlive-hyperref
texlive-latex-ms
texlive-latex-natbib
texlive-bibtex ; style files used by natbib
@@ -12776,7 +12776,7 @@ to an artifact/contaminant file.")
("zlib" ,zlib)))
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-latex-graphics
- texlive-latex-hyperref)))))
+ texlive-hyperref)))))
(home-page "https://www.ebi.ac.uk/~zerbino/velvet/")
(synopsis "Nucleic acid sequence assembler for very short reads")
(description
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index a886e59130..ccb4800d1c 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -114,8 +114,8 @@
;; for docs
("stex" ,stex)
("xorg-rgb" ,xorg-rgb)
- ("texlive" ,(texlive-updmap.cfg (list texlive-latex-oberdiek
- texlive-generic-epsf)))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-oberdiek
+ texlive-epsf)))
("ghostscript" ,ghostscript)
("netpbm" ,netpbm)))
(native-search-paths
@@ -316,10 +316,10 @@ and 32-bit PowerPC architectures.")
(native-inputs
`(("chez-scheme" ,chez-scheme)
("ghostscript" ,ghostscript)
- ("texlive" ,(texlive-updmap.cfg (list texlive-latex-oberdiek
- texlive-generic-epsf
+ ("texlive" ,(texlive-updmap.cfg (list texlive-oberdiek
+ texlive-epsf
texlive-metapost
- texlive-fonts-charter
+ texlive-charter
texlive-pdftex
texlive-context
texlive-cm
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 57f4687005..8a1ee88f81 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -524,7 +524,7 @@ featuring various improvements and bug fixes.")))
;; FIXME: with texlive-tiny citation references are rendered as question
;; marks. During the build warnings like these are printed:
;; LaTeX Warning: Citation `nabors91' on page 2 undefined on input line 3.
- `(("texlive" ,(texlive-updmap.cfg (list texlive-fonts-amsfonts)))
+ `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts)))
("ghostscript" ,ghostscript)))
(arguments
`(#:make-flags '("CC=gcc" "RM=rm" "SHELL=sh" "all")
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index feefa3a5f6..28964fbce2 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3313,7 +3313,7 @@ API.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)
- ("texlive" ,(texlive-updmap.cfg (list texlive-generic-epsf)))))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-epsf)))))
(inputs
`(("dbus-glib" ,dbus-glib)
("guile" ,guile-3.0)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1f8b592ff7..9ce31ba633 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5100,7 +5100,7 @@ set.")
texlive-latex-framed
texlive-latex-geometry
texlive-latex-hanging
- texlive-latex-hyperref
+ texlive-hyperref
texlive-latex-multirow
texlive-latex-natbib
texlive-latex-needspace
@@ -5112,7 +5112,7 @@ set.")
texlive-latex-tocloft
texlive-latex-upquote
texlive-latex-varwidth
- texlive-latex-wasysym
+ texlive-wasysym
texlive-latex-wrapfig)))))
(inputs
`(("blas" ,openblas)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 178f23c821..de49e1541a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1535,7 +1535,7 @@ and auto-mapping slices to MIDI note numbers.")
("imagemagick" ,imagemagick)
("netpbm" ,netpbm) ;for pngtopnm
("texlive" ,(texlive-updmap.cfg (list texlive-metapost
- texlive-generic-epsf
+ texlive-epsf
texlive-lh
texlive-latex-cyrillic)))
("texinfo" ,texinfo)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ada52b291e..9a36185ecb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7380,7 +7380,7 @@ browsers and Node.js.")
`(("which" ,which)
("texlive" ,(texlive-updmap.cfg
(list texlive-fonts-ec texlive-preprint
- texlive-latex-hyperref texlive-bibtex)))))
+ texlive-hyperref texlive-bibtex)))))
(propagated-inputs
`(("hevea" ,hevea)))
(home-page "https://www.lri.fr/~filliatr/bibtex2html/")
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 0b2c24c743..cb6ac63005 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -230,7 +230,7 @@ colors, styles, options and details.")
texlive-latex-base
texlive-latex-geometry
texlive-latex-graphics
- texlive-latex-oberdiek ; for ifluatex
+ texlive-oberdiek ;for ifluatex
texlive-latex-parskip
texlive-tex-texinfo)))))
(inputs
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acc7910f32..9801a3caf8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5287,16 +5287,16 @@ color scales, and color space conversion easy. It has support for:
("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)
("python-numpydoc" ,python-numpydoc)
- ("texlive" ,(texlive-updmap.cfg (list texlive-fonts-cm-super
+ ("texlive" ,(texlive-updmap.cfg (list texlive-cm-super
texlive-fonts-ec
- texlive-generic-ifxetex
- texlive-generic-pdftex
+ texlive-generic-iftex
+ texlive-pdftex
texlive-amsfonts
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ
texlive-latex-eqparbox
- texlive-latex-etoolbox
+ texlive-etoolbox
texlive-latex-expdlist
texlive-latex-fancyhdr
texlive-latex-fancyvrb
@@ -5305,11 +5305,11 @@ color scales, and color space conversion easy. It has support for:
texlive-latex-framed
texlive-latex-geometry
texlive-latex-graphics
- texlive-latex-hyperref
+ texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
texlive-latex-needspace
- texlive-latex-oberdiek
+ texlive-oberdiek
texlive-latex-parskip
texlive-latex-preview
texlive-latex-tabulary
@@ -5318,7 +5318,7 @@ color scales, and color space conversion easy. It has support for:
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
- texlive-latex-url
+ texlive-url
texlive-latex-varwidth
texlive-latex-wrapfig)))
("texinfo" ,texinfo)
@@ -5842,11 +5842,11 @@ toolkits.")
texlive-latex-type1cm
texlive-latex-ucs
- texlive-generic-pdftex
+ texlive-pdftex
texlive-fonts-ec
- texlive-fonts-adobe-times
- texlive-fonts-txfonts)))
+ texlive-times
+ texlive-txfonts)))
("texinfo" ,texinfo)
,@(package-native-inputs python-matplotlib)))
(arguments
@@ -8134,13 +8134,13 @@ computing.")
;; FIXME: It's possible that a smaller union would work just as well.
("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-fonts-ec
- texlive-generic-ifxetex
+ texlive-generic-iftex
texlive-pdftex
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ
texlive-latex-eqparbox
- texlive-latex-etoolbox
+ texlive-etoolbox
texlive-latex-expdlist
texlive-latex-fancyhdr
texlive-latex-fancyvrb
@@ -8149,11 +8149,11 @@ computing.")
texlive-latex-framed
texlive-latex-geometry
texlive-latex-graphics
- texlive-latex-hyperref
+ texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
texlive-latex-needspace
- texlive-latex-oberdiek
+ texlive-oberdiek
texlive-latex-parskip
texlive-latex-preview
texlive-latex-tabulary
@@ -8162,7 +8162,7 @@ computing.")
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
- texlive-latex-url
+ texlive-url
texlive-latex-varwidth
texlive-latex-wrapfig)))
("texinfo" ,texinfo)))))
@@ -11198,18 +11198,18 @@ time.")
texlive-eurosym
texlive-fonts-rsfs
texlive-generic-ulem
- texlive-iftex
+ texlive-generic-iftex
texlive-jknappen
texlive-latex-amsmath
texlive-latex-enumitem
texlive-latex-fancyvrb
texlive-latex-float
- texlive-latex-fontspec
+ texlive-fontspec
texlive-latex-geometry
- texlive-latex-hyperref
+ texlive-hyperref
texlive-latex-jknapltx
texlive-latex-ms
- texlive-latex-oberdiek
+ texlive-oberdiek
texlive-latex-parskip
texlive-latex-trimspaces
texlive-latex-upquote
@@ -24948,8 +24948,8 @@ By default it uses the open Python vulnerability database Safety DB.")
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-fonts-ec
- texlive-latex-hyperref
- texlive-latex-oberdiek
+ texlive-hyperref
+ texlive-oberdiek
texlive-lm
texlive-xcolor)))))
(arguments
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 804e2e6a8c..05ce641374 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -349,11 +349,11 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
texlive-latex-base
texlive-latex-fancyvrb
texlive-latex-graphics
- texlive-latex-hyperref
- texlive-latex-oberdiek
+ texlive-hyperref
+ texlive-oberdiek
texlive-latex-tools
texlive-latex-upquote
- texlive-latex-url
+ texlive-url
texlive-latex-xkeyval)))
("tzdata" ,tzdata-for-tests)
("xz" ,xz)))
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c2846793b2..58732462ae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4563,7 +4563,7 @@ rotated.")
#:trivial? #t))
(propagated-inputs
`(("texlive-latex-bigfoot" ,texlive-latex-bigfoot) ; for suffix
- ("texlive-latex-filemod" ,texlive-latex-filemod)
+ ("texlive-filemod" ,texlive-filemod)
("texlive-latex-graphics" ,texlive-latex-graphics)
("texlive-latex-ifplatform" ,texlive-latex-ifplatform)
("texlive-latex-l3kernel" ,texlive-latex-l3kernel) ; for expl3
@@ -7134,10 +7134,10 @@ develop documents with LaTeX, in a single application.")
#t)))))
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-fonts-adobe-palatino
- texlive-fonts-adobe-zapfding
+ texlive-palatino
+ texlive-zapfding
texlive-knuth-lib
- texlive-fonts-mflogo-font
+ texlive-mflogo-font
texlive-pdftex)))
("automake" ,automake)))
(home-page "https://www.gnu.org/software/teximpatient/")
@@ -7487,7 +7487,7 @@ striking out (line through words) and crossing out (/// over words).")
(base32
"05zdq7y3am109m5534ahqqp9x5iar3ha68v1r4zkrdly2mijxz2j"))))))
(propagated-inputs
- `(("texlive-latex-xcolor" ,texlive-latex-xcolor)))
+ `(("texlive-xcolor" ,texlive-xcolor)))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -8119,9 +8119,9 @@ for a wealth of support information.")
"091n27n4l3iac911bvmpp735ffryyzaq46mkclgn3q9jsvc4ngiv")
#:trivial? #t))
(propagated-inputs
- `(("texlive-latex-hyperref" ,texlive-latex-hyperref)
+ `(("texlive-hyperref" ,texlive-hyperref)
("texlive-oberdiek" ,texlive-oberdiek)
- ("texlive-latex-etoolbox" ,texlive-latex-etoolbox)
+ ("texlive-etoolbox" ,texlive-etoolbox)
("texlive-latex-pgf" ,texlive-latex-pgf)))
(home-page "https://www.ctan.org/pkg/beamer")
(synopsis "LaTeX class for producing presentations and slides")