summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-26 13:36:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-27 15:50:53 +0200
commitb7cb4e2822d1b2ee55ec5ca6f953561a219f4042 (patch)
tree4004337a364357e31b9e482fef8c5167795d9a32
parent4fb6ef6636acd7608889639c1b2e492517256f76 (diff)
downloadguix-patches-b7cb4e2822d1b2ee55ec5ca6f953561a219f4042.tar
guix-patches-b7cb4e2822d1b2ee55ec5ca6f953561a219f4042.tar.gz
gnu: Add r-saver.
* gnu/packages/cran.scm (r-saver): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 21cfca3102..85a18e6f8c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2333,6 +2333,41 @@ generate dynamic style sheets. The package uses the Sass CSS extension
language, which is stable, powerful, and CSS compatible.")
(license license:expat)))
+(define-public r-saver
+ (package
+ (name "r-saver")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SAVER" version))
+ (sha256
+ (base32
+ "1s1kw8idkaj7j90fw4qn9k0wd4vz0sblsk06ry6lm4afcar0p158"))))
+ (properties `((upstream-name . "SAVER")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-doparallel
+ r-foreach
+ r-glmnet
+ r-iterators
+ r-matrix))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mohuangx/SAVER")
+ (synopsis
+ "Recovery of gene expression profile in noisy and sparse scRNA-seq data")
+ (description
+ "This package is an implementation of a regularized regression prediction
+and empirical Bayes method to recover the true gene expression profile in noisy
+and sparse single-cell RNA-seq data. In @dfn{single-cell RNA sequencing}
+(scRNA-seq) studies, only a small fraction of the transcripts present in each
+cell are sequenced. This leads to unreliable quantification of genes with low
+or moderate expression, which hinders downstream analysis. This package
+@dfn{single-cell analysis via expression recovery} (SAVER) implements an
+expression recovery method for unique molecule index (UMI)-based scRNA-seq
+data that borrows information across genes and cells to provide accurate
+expression estimates for all genes.")
+ (license license:gpl2)))
+
;; This package includes minified JavaScript files. When upgrading please
;; check that there are no new minified JavaScript files.
(define-public r-bslib