summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:12:26 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:19 +0200
commitb2ac012d04e1978eabd3f9c4a60e5ba4b2fd8767 (patch)
tree97659905df02d6182bef06230510835076d9a9ba
parent8ff1dabe1e6243e80d2a06e173bdf1ec6aeebcac (diff)
downloadguix-patches-b2ac012d04e1978eabd3f9c4a60e5ba4b2fd8767.tar
guix-patches-b2ac012d04e1978eabd3f9c4a60e5ba4b2fd8767.tar.gz
gnu: Add kjobwidgets.
* gnu/packages/kde-frameworks.scm (kjobwidgets): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index eeedbddb1e..428a5251ed 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1262,3 +1262,31 @@ QtGui. As such it is not required for the compilation of any other software,
but may be a runtime requirement for Qt-based software to support certain image
formats.")
(license license:lgpl2.1+)))
+
+(define-public kjobwidgets
+ (package
+ (name "kjobwidgets")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1mcvrz66xcqjgbp08zpqsf943cm462wbqm5gh719p9s25hx8hwrc"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Widgets for showing progress of asynchronous jobs")
+ (description "KJobWIdgets provides widgets for showing progress of
+asynchronous jobs.")
+ (license license:lgpl2.1+)))