summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-28 17:33:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-28 23:00:47 +0200
commitb1ae0f30d856503fa311d380584a6d7c80559332 (patch)
treee776bbebaca1578b39dcee6f9fcbc422c3b67fbc
parent0b70eb03cbcf5df7de9f468d9e2a3b53379779fe (diff)
downloadguix-patches-b1ae0f30d856503fa311d380584a6d7c80559332.tar
guix-patches-b1ae0f30d856503fa311d380584a6d7c80559332.tar.gz
gnu: Add mosaicatcher.
* gnu/packages/bioinformatics.scm (mosaicatcher): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f38c0c07ef..2a7443314a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6170,6 +6170,46 @@ Roche 454, Ion Torrent and Pacific BioSciences SMRT.")
;; 2. MD5 implementation - RSA Data Security, RFC 1321
(license (list license:gpl2+ license:public-domain)))))
+(define-public mosaicatcher
+ (package
+ (name "mosaicatcher")
+ (version "0.3.1")
+ (source (origin
+ ;; There are no release tarballs nor tags.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/friendsofstrandseq/mosaicatcher")
+ (commit (string-append version "-dev"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n2s5wvvj2y0vfgjkg1q11xahpbagxz7h2vf5q7qyy25s12kbzbd"))
+ (patches (search-patches "mosaicatcher-unbundle-htslib.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #false ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "src")))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((target (assoc-ref outputs "out"))
+ (bin (string-append target "/bin"))
+ (share (string-append target "/share/mosaicatcher")))
+ (install-file "mosaic" bin)
+ (mkdir-p share)
+ (copy-recursively "../R" share)))))))
+ (inputs
+ `(("boost" ,boost)
+ ("htslib" ,htslib)))
+ (home-page "https://github.com/friendsofstrandseq/mosaicatcher")
+ (synopsis "Count and classify Strand-seq reads")
+ (description
+ "Mosaicatcher counts Strand-seq reads and classifies strand states of
+each chromosome in each cell using a Hidden Markov Model.")
+ (license license:expat)))
+
(define-public ngs-sdk
(package
(name "ngs-sdk")