summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-19 15:44:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-19 15:44:26 +0200
commitb16e08279938fae329e62154da749860bdccef04 (patch)
tree82199d58155f7f4e8060ff225974fd5208f06955
parentca49d732256fd768941b91b3e92404430832de27 (diff)
downloadguix-patches-b16e08279938fae329e62154da749860bdccef04.tar
guix-patches-b16e08279938fae329e62154da749860bdccef04.tar.gz
gnu: python-keras: Add upstream patch.
* gnu/packages/patches/python-keras-integration-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/machine-learning.scm (python-keras)[source](patches): New field.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/machine-learning.scm1
-rw-r--r--gnu/packages/patches/python-keras-integration-test.patch19
3 files changed, 21 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 01ec94484f..35775041b8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1225,6 +1225,7 @@ dist_patch_DATA = \
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
%D%/packages/patches/python-faker-fix-build-32bit.patch \
+ %D%/packages/patches/python-keras-integration-test.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e3c69948e2..3eeb9cb1e2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1853,6 +1853,7 @@ with image data, text data, and sequence data.")
(origin
(method url-fetch)
(uri (pypi-uri "Keras" version))
+ (patches (search-patches "python-keras-integration-test.patch"))
(sha256
(base32
"1j8bsqzh49vjdxy6l1k4iwax5vpjzniynyd041xjavdzvfii1dlh"))))
diff --git a/gnu/packages/patches/python-keras-integration-test.patch b/gnu/packages/patches/python-keras-integration-test.patch
new file mode 100644
index 0000000000..aa2b1a273d
--- /dev/null
+++ b/gnu/packages/patches/python-keras-integration-test.patch
@@ -0,0 +1,19 @@
+Fix a test failure with recent versions of ... Pytest? Python?
+
+Taken from upstream:
+https://github.com/keras-team/keras/commit/fe35050a8f18dc52304aa8da4e463eececa25240
+
+diff --git a/tests/integration_tests/applications_test.py b/tests/integration_tests/applications_test.py
+index 979f2f2abd6..6e3b57fa8e2 100644
+--- a/tests/integration_tests/applications_test.py
++++ b/tests/integration_tests/applications_test.py
+@@ -58,7 +58,8 @@ def _test_application_basic(app, last_dim=1000):
+ def _test_application_notop(app, last_dim):
+ output_shape = _get_output_shape(
+ lambda: app(weights=None, include_top=False))
+- assert output_shape == (None, None, None, last_dim)
++ assert len(output_shape) == 4
++ assert output_shape[-1] == last_dim
+
+
+ def test_mobilenet_v2_legacy_import():