summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-10 14:01:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-10 14:02:13 +0200
commitafed1b94f7902d3bd2cb2f49f6d2a6e9118cd345 (patch)
tree69d4f81f192144e89ba64af1ef9ddfc71ccb780b
parentcf197bff6ae1aec76ca05288a09a3631e46077e7 (diff)
downloadguix-patches-afed1b94f7902d3bd2cb2f49f6d2a6e9118cd345.tar
guix-patches-afed1b94f7902d3bd2cb2f49f6d2a6e9118cd345.tar.gz
gnu: stumpwm: Fix the Texinfo manual.
* gnu/packages/wm.scm (stumpwm)[native-inputs]: Add autoconf & automake. [arguments]: Bootstrap autotools & configure before making stumpwm.info.
-rw-r--r--gnu/packages/wm.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2c877038b1..58252e7095 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1597,7 +1597,11 @@ compositors that support the layer-shell protocol.")
(base32 "1ha8803ll7472kqxsy2xz0v5d4sv8apmc9z631d67m31q0z1m9rz"))))
(build-system asdf-build-system/sbcl)
(native-inputs `(("fiasco" ,sbcl-fiasco)
- ("texinfo" ,texinfo)))
+ ("texinfo" ,texinfo)
+
+ ;; To build the manual.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
(inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
("clx" ,sbcl-clx)
("alexandria" ,sbcl-alexandria)))
@@ -1631,13 +1635,12 @@ compositors that support the layer-shell protocol.")
out)))
#t)))
(add-after 'install 'install-manual
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The proper way to the manual is bootstrapping a full autotools
- ;; build system and running ‘./configure && make stumpwm.info’ to
- ;; do some macro substitution. We can get away with much less.
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(info (string-append out "/share/info")))
- (invoke "makeinfo" "stumpwm.texi.in")
+ (invoke "./autogen.sh")
+ (invoke "sh" "./configure" "SHELL=sh")
+ (apply invoke "make" "stumpwm.info" make-flags)
(install-file "stumpwm.info" info)
#t))))))
(synopsis "Window manager written in Common Lisp")