summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-07-29 01:13:34 -0500
committerBrett Gilio <brettg@gnu.org>2020-07-29 01:13:34 -0500
commitad6dfdcc6b89216f72821ff2e8085960f3f4b210 (patch)
treebd9c44a0cd4cb4347e8df3dfce9d7f72ec4beddd
parent8e04dcdb8f0a0484ca89841a46788dd4c128069e (diff)
downloadguix-patches-ad6dfdcc6b89216f72821ff2e8085960f3f4b210.tar
guix-patches-ad6dfdcc6b89216f72821ff2e8085960f3f4b210.tar.gz
gnu: emacs-erc-image: Disable make-autoloads phase.
* gnu/packages/emacs-xyz.scm (emacs-erc-image)[arguments]: Disable make-autoloads phase as it causes problematic behavior for the image module.
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44f8c44233..f8080b6556 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14179,7 +14179,7 @@ arXiv, Google Scholar, Library of Congress, etc.
(define-public emacs-erc-image
(let ((commit "82fb3871f02e24b1e880770b9a3d187aab43d0f0")
- (revision "1"))
+ (revision "3"))
(package
(name "emacs-erc-image")
(version (git-version "0" revision commit))
@@ -14194,6 +14194,13 @@ arXiv, Google Scholar, Library of Congress, etc.
(base32
"1q8mkf612fb4fjp8h4kbr107wn083iqfdgv8f80pcmil8y33dw9i"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ;; The package autoloader fails to provide
+ ;; the image module when handled by Guix.
+ ;; Disable this phase, and let the package
+ ;; handle the `eval-after-load' procedure.
+ (delete 'make-autoloads))))
(home-page "https://github.com/kidd/erc-image.el")
(synopsis "Show inlined images (png/jpg/gif/svg) in ERC buffers")
(description "This plugin subscribes to hooks @code{erc-insert-modify-hook}