summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Rosset <mike.rosset@gmail.com>2020-07-28 07:27:22 -0700
committerMathieu Othacehe <othacehe@gnu.org>2020-08-01 20:03:46 +0200
commita987f128b568a4981136d55741cb77e7eb2a544c (patch)
tree07c28255ac561e7787850902a6ae4856891c1225
parentdcb74405e185ed71b3d0640de85edc5ba865a839 (diff)
downloadguix-patches-a987f128b568a4981136d55741cb77e7eb2a544c.tar
guix-patches-a987f128b568a4981136d55741cb77e7eb2a544c.tar.gz
gnu: nomad: Update to 0.2.0-alpha.
* gnu/packages/guile-xyz.scm (nomad): Update to 0.2.0-alpha. This is a significant update to Nomad. This removes the majority of C code and replaces it with gobject introspection using g-golf. In the process the nomad package expression has changed significantly. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm52
1 files changed, 38 insertions, 14 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 5f7a93b8c6..2f5e745df6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357@gmail.com>
+;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,6 +67,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages hurd)
@@ -2954,7 +2956,7 @@ perform geometrical transforms on JPEG images.")
(define-public nomad
(package
(name "nomad")
- (version "0.1.2-alpha")
+ (version "0.2.0-alpha")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2963,7 +2965,7 @@ perform geometrical transforms on JPEG images.")
(file-name (git-file-name name version))
(sha256
(base32
- "1dnkr1hmvfkwgxd75dcf93pg39yfgawvdpzdhv991yhghv0qxc9h"))))
+ "1z2z5x37v1qrk2vb8qlz2yj030iirzzd0maa9fjxzlqkrg6krbaj"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2978,20 +2980,31 @@ perform geometrical transforms on JPEG images.")
(inputs
`(("guile" ,guile-2.2)
("guile-lib" ,guile2.2-lib)
- ("guile-gcrypt" ,guile2.2-gcrypt)
("guile-readline" ,guile2.2-readline)
+ ("guile-gcrypt" ,guile2.2-gcrypt)
("gnutls" ,gnutls)
("shroud" ,shroud)
("emacsy" ,emacsy-minimal)
("glib" ,glib)
("dbus-glib" ,dbus-glib)
("gtk+" ,gtk+)
+ ("gtk+:bin" ,gtk+ "bin")
("gtksourceview" ,gtksourceview)
("webkitgtk" ,webkitgtk)
+ ("g-golf" ,g-golf)
("xorg-server" ,xorg-server)))
(propagated-inputs
`(("glib" ,glib)
("glib-networking" ,glib-networking)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gst-plugins-ugly" ,gst-plugins-ugly)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("vte" ,vte)
+ ("webkitgtk" ,webkitgtk)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -2999,9 +3012,6 @@ perform geometrical transforms on JPEG images.")
(ice-9 popen)
(ice-9 rdelim)
(srfi srfi-26))
- #:configure-flags
- ;; Ignore ‘error: ‘GTimeVal’ is deprecated: Use 'GDateTime' instead.’
- (list "CFLAGS=-Wno-error")
#:phases
(modify-phases %standard-phases
(add-before 'check 'start-xorg-server
@@ -3014,9 +3024,16 @@ perform geometrical transforms on JPEG images.")
(add-after 'install 'wrap-binaries
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (gio-deps (map (cut assoc-ref inputs <>) '("glib-networking"
- "glib")))
- (gio-mod-path (map (cut string-append <> "/lib/gio/modules")
+ (gio-deps (map (cut assoc-ref inputs <>)
+ '("glib-networking"
+ "glib"
+ "gstreamer"
+ "gst-plugins-base"
+ "gst-plugins-good"
+ "gst-plugins-bad"
+ "gst-plugins-ugly")))
+ (gio-mod-path (map (cut string-append <>
+ "/lib/gio/modules")
gio-deps))
(effective (read-line (open-pipe*
OPEN_READ
@@ -3024,7 +3041,7 @@ perform geometrical transforms on JPEG images.")
"(display (effective-version))")))
(deps (map (cut assoc-ref inputs <>)
'("emacsy" "guile-lib" "guile-readline"
- "shroud")))
+ "g-golf" "shroud")))
(scm-path (map (cut string-append <>
"/share/guile/site/" effective)
`(,out ,@deps)))
@@ -3040,12 +3057,19 @@ perform geometrical transforms on JPEG images.")
prefix ,go-path))
progs)
#t))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GI_TYPELIB_PATH")
+ (separator ":")
+ (files '("lib/girepository-1.0")))
+ (search-path-specification
+ (variable "NOMAD_WEB_EXTENSION_DIR")
+ (separator ":")
+ (files '("libexec/nomad")))))
(home-page "https://savannah.nongnu.org/projects/nomad/")
(synopsis "Extensible Web Browser in Guile Scheme")
- (description "Nomad is an Emacs-like Web Browser built using Webkitgtk and
-Emacsy. It has a small C layer and most browser features are fully
-programmable in Guile. It has hooks, keymaps, and self documentation
-features.")
+ (description "Nomad is a Emacs-like web browser that consists of a modular
+feature-set, fully programmable in Guile Scheme.")
(license license:gpl3+)))
(define-public guile-cv