summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-01-27 21:48:33 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-28 14:12:30 +0100
commita6b50a183258c011a7f33715883a7649316ca9d4 (patch)
tree09df4d9fa60d2bab93e21b78cea8203e5d53b10a
parent4e89e8b5dd762a510544d305d46c166cefe06266 (diff)
downloadguix-patches-a6b50a183258c011a7f33715883a7649316ca9d4.tar
guix-patches-a6b50a183258c011a7f33715883a7649316ca9d4.tar.gz
gnu: Add python-pywal.
* gnu/packages/python-xyz.scm (python-pywal): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b8e538168..d903a678a9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,6 +94,7 @@
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -145,6 +146,7 @@
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
@@ -6057,6 +6059,38 @@ similar to Fourier transforms, the difference being that Fourier transforms are
localized only in frequency instead of in time and frequency.")
(license license:expat)))
+(define-public python-pywal
+ (package
+ (name "python-pywal")
+ (version "3.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dylanaraps/pywal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "039m7dch479hlwddynacdrr0klz6a5bdly5swqbs94hfimficiyf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-home-directory
+ (lambda _
+ ;; Tests fail with "Permission denied: '/homeless-shelter'".
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (inputs
+ `(("imagemagick" ,imagemagick)))
+ (home-page "https://github.com/dylanaraps/pywal")
+ (synopsis "Color palette generator and applicator")
+ (description
+ "Pywal is a tool that generates a color palette from the dominant colors
+in an image. It then applies the colors system-wide and on-the-fly in all of
+your favourite programs.")
+ (license license:expat)))
+
(define-public python-pywinrm
(package
(name "python-pywinrm")