summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-07-19 23:28:59 +0200
committerMarius Bakke <marius@gnu.org>2022-07-20 16:50:08 +0200
commita61d5df8c3083b9fd4d9db39708691da62d0eab3 (patch)
tree6cd7e806cd978ae728163825bf3f9a0938ec9270
parentc8f33b613e55322f0fc7dbdd72566aeb2f8f6dad (diff)
downloadguix-patches-a61d5df8c3083b9fd4d9db39708691da62d0eab3.tar
guix-patches-a61d5df8c3083b9fd4d9db39708691da62d0eab3.tar.gz
gnu: Add node-buffer-crc32.
* gnu/packages/node-xyz.scm (node-buffer-crc32): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/node-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9dcb5c3d16..d025436465 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -56,6 +56,34 @@
architecture supporting plugins.")
(license license:expat)))
+(define-public node-buffer-crc32
+ (package
+ (name "node-buffer-crc32")
+ (version "0.2.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brianloveswords/buffer-crc32")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09qx2mnd898190m50mc0rhyvbm7d677sxz9bn09qmqkz6fnsddgf"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "npm" "--offline" "--ignore-scripts" "install"
+ "--production"))))))
+ (home-page "https://github.com/brianloveswords/buffer-crc32")
+ (synopsis "CRC32 implementation in Javascript")
+ (description
+ "This package provides a CRC32 algorithm that works with binary data
+and fancy character sets, signed or unsigned data and has tests, for Node.")
+ (license license:expat)))
+
(define-public node-color-name
(package
(name "node-color-name")