summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-06 19:15:06 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-06 19:50:31 +0200
commita5dbc07d38d3ae1a66a478efb959f74cce93b51f (patch)
tree30e0417f2d3f0e388c5a4458879e4351a7ca3493
parent28f7ef86cea4dd9399db6c0adc200cd9d2b3b687 (diff)
downloadguix-patches-a5dbc07d38d3ae1a66a478efb959f74cce93b51f.tar
guix-patches-a5dbc07d38d3ae1a66a478efb959f74cce93b51f.tar.gz
gnu: vim: Update to 8.2.1145.
* gnu/packages/vim.scm (vim): Update to 8.2.1145. [arguments]: Patch the terminal2 test too, as it has been split from test_terminal. Make the name of the phase more accurate. (vim-full)[arguments]: Remove the skip-test87 phase, as the test no longer exists and its successor passes.
-rw-r--r--gnu/packages/vim.scm22
1 files changed, 5 insertions, 17 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 44d81bb5f5..df6359351f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -70,7 +70,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.1101")
+ (version "8.2.1145")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -79,21 +79,22 @@
(file-name (git-file-name name version))
(sha256
(base32
- "170k855vscixnk6rz01i3k22crjiz8b2h83fnm2b2ccha0jyn9mf"))))
+ "01z5hgi7m8d63gl1fgfn4p9rsdaqbl5xn4vr247nbxjq5x5hrs7a"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'configure 'patch-config-files
+ (add-after 'configure 'patch-absolute-paths
(lambda _
(substitute* "runtime/tools/mve.awk"
(("/usr/bin/nawk") (which "gawk")))
(substitute* '("src/testdir/Makefile"
"src/testdir/test_normal.vim"
"src/testdir/test_system.vim"
- "src/testdir/test_terminal.vim")
+ "src/testdir/test_terminal.vim"
+ "src/testdir/test_terminal2.vim")
(("/bin/sh") (which "sh")))
(substitute* "src/testdir/test_autocmd.vim"
(("/bin/kill") (which "kill")))
@@ -214,19 +215,6 @@ with the editor vim.")))
,@(substitute-keyword-arguments (package-arguments vim)
((#:phases phases)
`(modify-phases ,phases
- (add-before 'check 'skip-test87
- ;; This test fails for unknown reasons after switching
- ;; to a git checkout.
- (lambda _
- (delete-file "src/testdir/test87.ok")
- (delete-file "src/testdir/test87.in")
- (substitute* '("src/Makefile"
- "src/testdir/Make_vms.mms")
- (("test87") ""))
- (substitute* "src/testdir/Make_all.mak"
- (("test86.out \\\\") "test86")
- (("test87.out") ""))
- #t))
(add-before 'check 'start-xserver
(lambda* (#:key inputs #:allow-other-keys)
;; Some tests require an X server, but does not start one.