summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 20:05:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 20:05:15 +0300
commita56b000745029bc457f01ad87d2e36f83823337b (patch)
tree36c764f8a388bddce56b60f4a64cc5870fa105a1
parentaf4ce7bd413c3a50733bfcc05370903a1e3808bc (diff)
downloadguix-patches-a56b000745029bc457f01ad87d2e36f83823337b.tar
guix-patches-a56b000745029bc457f01ad87d2e36f83823337b.tar.gz
gnu: python-deprecated: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-deprecated)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7b1e0efe2..d5b21d8352 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4362,8 +4362,9 @@ software version simply.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(propagated-inputs
`(("python-wrapt" ,python-wrapt)))
(native-inputs