summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-08 21:39:10 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-11 10:15:38 +0200
commita232a40b0011ef3200954f0f5e082e9adfeab2e1 (patch)
tree76669063bbb3d79c3e835d725ea9134fb69e9131
parent4a1fd4a5371b23e1fbf793c33124af08db45a8cd (diff)
downloadguix-patches-a232a40b0011ef3200954f0f5e082e9adfeab2e1.tar
guix-patches-a232a40b0011ef3200954f0f5e082e9adfeab2e1.tar.gz
gnu: Add cl-trivial-main-thread.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-main-thread, ecl-trivial-main-thread, cl-trivial-main-thread): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bd812eb7cb..2df35d2500 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16543,3 +16543,37 @@ allow to wrangle OpenGL Shader Language (GLSL) source files.")
(define-public cl-simple-tasks
(sbcl-package->cl-source-package sbcl-simple-tasks))
+
+(define-public sbcl-trivial-main-thread
+ (let ((commit "25f114973bb69eb63e01d0bbfead31f8e682846a")
+ (revision "1"))
+ (package
+ (name "sbcl-trivial-main-thread")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/trivial-main-thread")
+ (commit commit)))
+ (file-name (git-file-name "trivial-main-thread" version))
+ (sha256
+ (base32 "0bw1887i7396lqg75qvmgjfzz4xbiq9w5dp8wxdgrcsm0qwlraw7"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("simple-tasks" ,sbcl-simple-tasks)
+ ("trivial-features" ,sbcl-trivial-features)))
+ (home-page "https://shinmera.github.io/trivial-main-thread/")
+ (synopsis "Compatibility library to run things in the main thread")
+ (description
+ "This package provides a Common Lisp system which wraps the
+BORDEAUX-THREADS system to be able to run things in the main thread of the
+implementation, for example drawing calls of GUI applications.")
+ (license license:zlib))))
+
+(define-public ecl-trivial-main-thread
+ (sbcl-package->ecl-package sbcl-trivial-main-thread))
+
+(define-public cl-trivial-main-thread
+ (sbcl-package->cl-source-package sbcl-trivial-main-thread))