summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:35:20 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:14 +0100
commita1dd43e4cd35b6028beb1515960661ba0476dc61 (patch)
tree2bf98c1116799f0e2d5a6e9e670bbdb36f4389b7
parent5ce5e49c10b932743b730801632c5212ea8f7ed6 (diff)
downloadguix-patches-a1dd43e4cd35b6028beb1515960661ba0476dc61.tar
guix-patches-a1dd43e4cd35b6028beb1515960661ba0476dc61.tar.gz
gnu: Add r-lwgeom.
* gnu/packages/cran.scm (r-lwgeom): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 89a7c4f0cc..39d11dd8ee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27848,3 +27848,34 @@ and formatted text files with additional meta-data, such including @code{.csv},
(description
"Algorithms to find arrangements of non-overlapping circles.")
(license license:expat)))
+
+;; Cannot unbundle liblwgeom, because PostGIS does not support building it on
+;; its own.
+(define-public r-lwgeom
+ (package
+ (name "r-lwgeom")
+ (version "0.2-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lwgeom" version))
+ (sha256
+ (base32
+ "0byhjqa2acns8mznl1ngnfygxxxyszvnq66qfg0smhhhdkwr67aa"))))
+ (properties `((upstream-name . "lwgeom")))
+ (build-system r-build-system)
+ (inputs `(("geos" ,geos) ("proj" ,proj) ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-sf" ,r-sf)
+ ("r-units" ,r-units)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page
+ "https://github.com/r-spatial/lwgeom/")
+ (synopsis
+ "Bindings to Selected 'liblwgeom' Functions for Simple Features")
+ (description
+ "Access to selected functions found in
+@url{https://github.com/postgis/postgis/tree/master/liblwgeom,liblwgeom}, the
+light-weight geometry library used by @url{http://postgis.net/,PostGIS}.")
+ (license license:gpl2)))