summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 12:09:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 12:10:23 +0100
commita1b3c6be4cdc16986f879f4757c868dbd0fa5b6e (patch)
tree24f4b5e01d314e537044848f9cabc94ceb1cac33
parentac37bd4652c05704f900ea29d67ec72f5f33b385 (diff)
downloadguix-patches-a1b3c6be4cdc16986f879f4757c868dbd0fa5b6e.tar
guix-patches-a1b3c6be4cdc16986f879f4757c868dbd0fa5b6e.tar.gz
gnu: Add r-keyring.
* gnu/packages/cran.scm (r-keyring): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 843f376432..b48b5f1e08 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22246,6 +22246,39 @@ a formula and @code{data.frame} plus some additional arguments for priors.")
trend test.")
(license license:gpl2+)))
+(define-public r-keyring
+ (package
+ (name "r-keyring")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "keyring" version))
+ (sha256
+ (base32
+ "1hpfd4hbx43i39l995rg86kfxi7wlyla1gv8mwcdr4xx7z122zzq"))))
+ (properties `((upstream-name . "keyring")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-filelock" ,r-filelock)
+ ("r-getpass" ,r-getpass)
+ ("r-openssl" ,r-openssl)
+ ("r-r6" ,r-r6)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-sodium" ,r-sodium)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/r-lib/keyring")
+ (synopsis "Access the system credential store from R")
+ (description
+ "This package provides a platform-independent API to access the operating
+system's credential store. It currently supports Keychain on macOS,
+Credential Store on Windows, the Secret Service API on GNU/Linux, and a
+simple, platform independent store implemented with environment variables.
+Additional storage back-ends can be added easily.")
+ (license license:expat)))
+
(define-public r-zyp
(package
(name "r-zyp")