summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-13 22:50:36 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-13 23:45:55 +0800
commita124bbd2f41410e1c33654f4ff9865765baf28a7 (patch)
tree9c616d93caf0938e303b22fde2e3d4fcd09f8dda
parentd777e048b5244dd264e1314b51f871af21ae9985 (diff)
downloadguix-patches-a124bbd2f41410e1c33654f4ff9865765baf28a7.tar
guix-patches-a124bbd2f41410e1c33654f4ff9865765baf28a7.tar.gz
gnu: Adjust formatting as recommended by 'guix lint'.
* gnu/packages/aidc.scm (barcode, qrencode), gnu/packages/bash.scm (bash, bash-completion), gnu/packages/busybox.scm (busybox), gnu/packages/cdrom.scm (cdparanoia), gnu/packages/cmake.scm (cmake), gnu/packages/conkeror.scm (conkeror), gnu/packages/cook.scm (cook), gnu/packages/curl.scm (curl), gnu/packages/docbook.scm (docbook-xsl), gnu/packages/enlightenment.scm (enlightenment), gnu/packages/games.scm (abbaye), gnu/packages/geeqie.scm (exiv2), gnu/packages/gimp.scm (gegl), gnu/packages/gl.scm (glu, freeglut, ftgl), gnu/packages/glib.scm (glib), gnu/packages/gnome.scm (orbit2, gconf, geocode-glib), gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base), gnu/packages/linux.scm (util-linux), gnu/packages/lisp.scm (gcl, ecl), gnu/packages/maths.scm (gnuplot, hdf5), gnu/packages/ssh.scm (dropbear), gnu/packages/web.scm (json-c): Remove tabulations and trailing white spaces or reformat to fit within 80 columns. * gnu/packages/audio.scm (aubio), gnu/packages/emacs.scm (emacs-s), gnu/packages/engineering.scm (geda-gaf), gnu/packages/games.scm (dosbox), gnu/packages/gnome.scm (gusb), gnu/packages/gtk.scm (gtk+), gnu/packages/guile.scm (guile-wisp), gnu/packages/hurd.scm (hurd-headers), gnu/packages/wm.scm (i3-wm): Adjust synopsis or description.
-rw-r--r--gnu/packages/aidc.scm9
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/bash.scm8
-rw-r--r--gnu/packages/busybox.scm10
-rw-r--r--gnu/packages/cdrom.scm3
-rw-r--r--gnu/packages/cmake.scm3
-rw-r--r--gnu/packages/conkeror.scm8
-rw-r--r--gnu/packages/cook.scm8
-rw-r--r--gnu/packages/curl.scm4
-rw-r--r--gnu/packages/docbook.scm5
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/enlightenment.scm2
-rw-r--r--gnu/packages/games.scm6
-rw-r--r--gnu/packages/geeqie.scm3
-rw-r--r--gnu/packages/gimp.scm2
-rw-r--r--gnu/packages/gl.scm53
-rw-r--r--gnu/packages/glib.scm3
-rw-r--r--gnu/packages/gnome.scm44
-rw-r--r--gnu/packages/gstreamer.scm9
-rw-r--r--gnu/packages/gtk.scm2
-rw-r--r--gnu/packages/guile.scm4
-rw-r--r--gnu/packages/hurd.scm2
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/lisp.scm14
-rw-r--r--gnu/packages/maths.scm6
-rw-r--r--gnu/packages/ssh.scm3
-rw-r--r--gnu/packages/web.scm5
-rw-r--r--gnu/packages/wm.scm2
29 files changed, 122 insertions, 104 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 02254c8547..3ef5d28fbb 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -33,9 +33,10 @@
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/barcode/barcode-"
- version ".tar.xz"))
- (sha256 (base32
- "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
(build-system gnu-build-system)
(synopsis "Convert text strings to printed bars in various standards")
(description "GNU Barcode is a flexible tool to produce printed barcodes
@@ -53,7 +54,7 @@ formats.")
(method url-fetch)
(uri (string-append
"http://fukuchi.org/works/qrencode/qrencode-" version
- ".tar.bz2"))
+ ".tar.bz2"))
(sha256 (base32
"163sb580p570p27imc6jhkfdw15kzp8vy1jq92nip1rwa63i9myz"))))
(build-system gnu-build-system)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a6899a07f6..77842f8c48 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -128,7 +128,7 @@ Filter) modules follow the convention of 1V / Octave.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://aubio.org/")
- (synopsis "A library for audio labelling")
+ (synopsis "Library for audio labelling")
(description
"aubio is a tool designed for the extraction of annotations from audio
signals. Its features include segmenting a sound file before each of its
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 180c64e872..bdb5a760f7 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -191,7 +191,7 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
;; Bash is reportedly not parallel-safe. See, for instance,
;; <http://patches.openembedded.org/patch/32745/> and
- ;; <http://git.buildroot.net/buildroot/commit/?h=79e2d802ae7e376a413c02097790493e1f65c3a4>.
+ ;; <http://git.buildroot.net/buildroot/commit/?h=79e2d802a>.
#:parallel-build? #f
#:parallel-tests? #f
@@ -290,8 +290,10 @@ without modification.")
(completions (string-append out
"/share/bash-completion"
"/completions"))
- (already (find-files (string-append util-linux
- "/etc/bash_completion.d"))))
+ (already (find-files
+ (string-append
+ util-linux
+ "/etc/bash_completion.d"))))
(with-directory-excursion completions
(for-each (lambda (file)
(when (file-exists? file)
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 13630b39dc..e2d6cf8f9e 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -40,12 +40,12 @@
"12v7nri79v8gns3inmz4k24q7pcnwi00hybs0wddfkcy1afh42xf"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:phases
(alist-replace
- 'configure
+ 'configure
(lambda _ (zero? (system* "make" "defconfig")))
(alist-replace
- 'check
+ 'check
(lambda _
(substitute* '("testsuite/du/du-s-works"
"testsuite/du/du-works")
@@ -70,7 +70,7 @@
;; So mark it with SKIP_KNOWN_BUGS like the others.
;; Presumably it wasn't known at the time of release ...
;; (It is strange that they release software which they know to have bugs)
- (("testing \"grep -w \\^str doesn't match str not at the beginning\"")
+ (("testing \"grep -w \\^str doesn't match str not at the beginning\"")
"test x\"$SKIP_KNOWN_BUGS\" = x\"\" && testing \"grep -w ^str doesn't match str not at the beginning\""))
;; This test cannot possibly pass.
@@ -79,7 +79,7 @@
(delete-file "testsuite/which/which-uses-default-path")
(rmdir "testsuite/which")
- (zero? (system* "make"
+ (zero? (system* "make"
;; "V=1"
"SKIP_KNOWN_BUGS=1"
"SKIP_INTERNET_TESTS=1"
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 884ba8bfa6..9a216f789d 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -157,7 +157,8 @@ files.")
(version "10.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-"
+ (uri (string-append "http://downloads.xiph.org/releases/"
+ "cdparanoia/cdparanoia-III-"
version ".src.tgz"))
(sha256
(base32
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index a58284ba17..2efce6fd87 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -66,7 +66,8 @@
"Source/cmExecProgramCommand.cxx"
"Utilities/cmbzip2/Makefile-libbz2_so"
"Utilities/Release/release_cmake.cmake"
- "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
+ "Utilities/cmlibarchive/libarchive/\
+archive_write_set_format_shar.c"
"Tests/CMakeLists.txt"
"Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
(("/bin/sh") (which "sh"))))
diff --git a/gnu/packages/conkeror.scm b/gnu/packages/conkeror.scm
index d91fe9e78b..cfeb22e8c3 100644
--- a/gnu/packages/conkeror.scm
+++ b/gnu/packages/conkeror.scm
@@ -76,7 +76,7 @@ services (Search, Gmail, Maps, Reader, etc.), Del.icio.us, Reddit, Last.fm and
YouTube. For easier editing of form fields, it can spawn external editors.")
(home-page "http://conkeror.org")
;; Conkeror is triple licensed.
- (license (list license:gpl2
- license:lgpl2.1
- ;; MPL 1.1 -- this license is not GPL compatible
- ))))
+ (license (list
+ ;; MPL 1.1 -- this license is not GPL compatible
+ license:gpl2
+ license:lgpl2.1))))
diff --git a/gnu/packages/cook.scm b/gnu/packages/cook.scm
index 4eb3096153..d0dd80dc40 100644
--- a/gnu/packages/cook.scm
+++ b/gnu/packages/cook.scm
@@ -35,17 +35,17 @@
(method url-fetch)
(uri (string-append
"http://miller.emu.id.au/pmiller/software/cook/cook-" version
- ".tar.gz"))
+ ".tar.gz"))
(sha256
(base32
"104saqnqql1l7zr2pm3f718fdky3ds8j07c6xvwrs1rfkhrw58yw"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
- #:phases
+ #:phases
(alist-cons-before
'configure 'pre-conf
- (lambda _
+ (lambda _
(substitute* (append '("common/env.c")
(find-files "test" "\\.sh"))
(("/bin/sh") (which "sh")))
@@ -57,7 +57,7 @@
;; which plays havoc with this test, for which correct timestamps
;; are very important. Adding the U flag undoes the effect of
;; --enable-deterministic-archives and allows this test to work
- ;; again.
+ ;; again.
(substitute* "test/00/t0077a.sh"
(("ar qc") "ar qcU"))
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 3e435f4b13..16140f0f9c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -95,8 +95,8 @@
;; test 1510...[HTTP GET connection cache limit (CURLOPT_MAXCONNECTS)]
;;
;; 1510: output (log/stderr1510) FAILED:
- ;; --- log/check-expected 2015-06-27 07:45:53.166720834 +0000
- ;; +++ log/check-generated 2015-06-27 07:45:53.166720834 +0000
+ ;; --- log/check-expected 2015-06-27 07:45:53.166720834 +0000
+ ;; +++ log/check-generated 2015-06-27 07:45:53.166720834 +0000
;; @@ -1,5 +1,5 @@
;; * Connection #0 to host server1.example.com left intact[LF]
;; * Connection #1 to host server2.example.com left intact[LF]
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 3ec0377f57..9f5fbf1d96 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -134,8 +134,9 @@ by no means limited to these applications.) This package provides XML DTDs.")
(string-append xsl "/" name-version))
(substitute* (string-append xsl "/" name-version "/catalog.xml")
- (("rewritePrefix=\"./")
- (string-append "rewritePrefix=\"file://" xsl "/" name-version "/")))))
+ (("rewritePrefix=\"./")
+ (string-append "rewritePrefix=\"file://" xsl "/"
+ name-version "/")))))
#:modules ((guix build utils))))
(native-inputs `(("bzip2" ,bzip2)
("tar" ,tar)))
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f8be743ce5..67f1ea20ef 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1023,7 +1023,7 @@ and stored in memory.")
(lambda _
(zero? (system* "./run-tests.sh")))))))
(home-page "https://github.com/magnars/s.el")
- (synopsis "Emacs string manipulation library.")
+ (synopsis "Emacs string manipulation library")
(description "This package provides an Emacs library for manipulating
strings.")
(license license:gpl3+)))
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 1c378f63a7..554399b049 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -140,7 +140,7 @@ plans and designs.")
(home-page "http://geda-project.org/")
(synopsis "Schematic capture, netlister, symbols, symbol checker, and utils")
(description
- "gaf stands for “gschem and friends”. It is a subset of the entire tool
+ "Gaf stands for “gschem and friends”. It is a subset of the entire tool
suite grouped together under the gEDA name. gEDA/gaf is a collection of tools
which currently includes: gschem, a schematic capture program; gnetlist, a
netlist generation program; gsymcheck, a syntax checker for schematic symbols;
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 0a91995a0a..97e7d38215 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -277,7 +277,7 @@ Libraries with some extra bells and whistles.")
(string-append "https://download.enlightenment.org/rel/apps/"
name "/" name "-" version ".tar.xz"))
(sha256
- (base32
+ (base32
"098bdx9qmv1yqqwfydrzs7fvbnhsf3vaib9pmqsyg4ihgqrkrwjm"))))
(build-system gnu-build-system)
(native-inputs
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4274d4ce38..8dcedc11e8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -158,8 +158,8 @@ scriptable with Guile.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://abbaye-for-linux.googlecode.com/files/abbaye-for-linux-src-"
- version ".tar.gz"))
+ (uri (string-append "http://abbaye-for-linux.googlecode.com/files/"
+ "abbaye-for-linux-src-" version ".tar.gz"))
(sha256
(base32
"1wgvckgqa2084rbskxif58wbb83xbas8s1i8s7d57xbj08ryq8rk"))))
@@ -1089,7 +1089,7 @@ next campaign.")
("glu" ,glu)
("mesa" ,mesa)))
(home-page "http://www.dosbox.com")
- (synopsis "x86 emulator with CGA/EGA/VGA/etc. graphics and sound")
+ (synopsis "X86 emulator with CGA/EGA/VGA/etc. graphics and sound")
(description "DOSBox is a DOS-emulator that uses the SDL library. DOSBox
also emulates CPU:286/386 realmode/protected mode, Directory
FileSystem/XMS/EMS, Tandy/Hercules/CGA/EGA/VGA/VESA graphics, a
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
index a192c4b009..9cc8f74255 100644
--- a/gnu/packages/geeqie.scm
+++ b/gnu/packages/geeqie.scm
@@ -53,7 +53,8 @@ and XMP metadata of images in various formats.")
;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
- ;; The core is GPLv2+: <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
+ ;; The core is GPLv2+:
+ ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
(license l:gpl2+)))
(define-public geeqie
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 35c55dc2f9..ebf66d478e 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -68,7 +68,7 @@ provided as well as the framework to add new color models and data types.")
(version "0.2.0")
(source (origin
(method url-fetch)
- (uri (list (string-append "http://download.gimp.org/pub/gegl/"
+ (uri (list (string-append "http://download.gimp.org/pub/gegl/"
(string-take version 3)
"/" name "-" version ".tar.bz2")))
(sha256
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c7bece868d..33312ba127 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -49,14 +49,15 @@
(name "glu")
(version "9.0.0")
(source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
- version ".tar.gz"))
- (sha256
- (base32 "0r72yyhj09x3krn3kn629jqbwyq50ji8w5ri2pn6zwrk35m4g1s3"))))
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0r72yyhj09x3krn3kn629jqbwyq50ji8w5ri2pn6zwrk35m4g1s3"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("mesa" ,mesa))) ; according to glu.pc
+ `(("mesa" ,mesa))) ; according to glu.pc
(home-page "http://www.opengl.org/archives/resources/faq/technical/glu.htm")
(synopsis "Mesa OpenGL Utility library")
(description
@@ -77,20 +78,22 @@ as ASCII text.")
(name "freeglut")
(version "3.0.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/project/freeglut/freeglut/"
- version "/freeglut-" version ".tar.gz"))
- (sha256
- (base32 "18knkyczzwbmyg8hr4zh8a1i5ga01np2jzd1rwmsh7mh2n2vwhra"))))
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/project/freeglut/freeglut/"
+ version "/freeglut-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18knkyczzwbmyg8hr4zh8a1i5ga01np2jzd1rwmsh7mh2n2vwhra"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no test target
(inputs `(("mesa" ,mesa)
- ("libx11" ,libx11)
- ("libxi" ,libxi)
- ("libxrandr" ,libxrandr)
- ("libxxf86vm" ,libxxf86vm)
- ("inputproto" ,inputproto)
- ("xinput" ,xinput)))
+ ("libx11" ,libx11)
+ ("libxi" ,libxi)
+ ("libxrandr" ,libxrandr)
+ ("libxxf86vm" ,libxxf86vm)
+ ("inputproto" ,inputproto)
+ ("xinput" ,xinput)))
(propagated-inputs
;; Headers from Mesa and GLU are needed.
`(("glu" ,glu)
@@ -116,17 +119,19 @@ the X-Consortium license.")
(name "ftgl")
(version "2.1.3-rc5")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/project/ftgl/FTGL%20Source/2.1.3~rc5/ftgl-"
- version ".tar.gz"))
- (sha256
- (base32 "0nsn4s6vnv5xcgxcw6q031amvh2zfj2smy1r5mbnjj2548hxcn2l"))))
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/project/ftgl/FTGL%20Source/2.1.3~rc5/"
+ "ftgl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nsn4s6vnv5xcgxcw6q031amvh2zfj2smy1r5mbnjj2548hxcn2l"))))
(build-system gnu-build-system)
;; The pkg-config file lists "freetype2" as Requires.private.
(propagated-inputs `(("freetype" ,freetype)))
(inputs `(("libx11" ,libx11)
- ("mesa" ,mesa)
- ("glu" ,glu)))
+ ("mesa" ,mesa)
+ ("glu" ,glu)))
(home-page "http://ftgl.sourceforge.net")
(synopsis "Font rendering library for OpenGL applications")
(description
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index b2979b24e4..146d3f563b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -188,7 +188,8 @@ shared NFS home directories.")
;; Disable a test that requires dbus.
(substitute* "gio/tests/gdbus-serialization.c"
- (("g_test_add_func \\(\"/gdbus/message-serialize/double-array\", test_double_array\\);" all)
+ (("g_test_add_func \
+\\(\"/gdbus/message-serialize/double-array\", test_double_array\\);" all)
(string-append "/* " all " */"))))
%standard-phases)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 79846ae2e8..4bd9d9c881 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -930,23 +930,26 @@ functionality was designed to be as reusable and portable as possible.")
(source (origin
(method url-fetch)
(uri (let ((upstream-name "ORBit2"))
- (string-append "mirror://gnome/sources/" upstream-name "/"
+ (string-append "mirror://gnome/sources/" upstream-name "/"
(version-major+minor version) "/"
upstream-name "-" version ".tar.bz2")))
(sha256
- (base32 "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
+ (base32
+ "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
(build-system gnu-build-system)
(arguments
- ;; The programmer kindly gives us a hook to turn off deprecation warnings ...
- `(#:configure-flags '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
- ;; ... which they then completly ignore !!
- #:phases
- (alist-cons-before
- 'configure 'ignore-deprecations
- (lambda _
- (substitute* "linc2/src/Makefile.in"
- (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))
- %standard-phases)))
+ `(#:configure-flags
+ ;; The programmer kindly gives us a hook to turn off deprecation
+ ;; warnings ...
+ '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ ;; ... which they then completly ignore !!
+ #:phases
+ (alist-cons-before
+ 'configure 'ignore-deprecations
+ (lambda _
+ (substitute* "linc2/src/Makefile.in"
+ (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))
+ %standard-phases)))
(inputs `(("glib" ,glib)
("libidl" ,libidl)))
(native-inputs
@@ -955,9 +958,9 @@ functionality was designed to be as reusable and portable as possible.")
(synopsis "CORBA 2.4-compliant Object Request Broker")
(description "ORBit2 is a CORBA 2.4-compliant Object Request Broker (orb)
featuring mature C, C++ and Python bindings.")
- ;; Licence notice is unclear. The Web page simply say "GPL" without giving a version.
- ;; SOME of the code files have licence notices for GPLv2+
- ;; The tarball contains files of the text of GPLv2 and LGPLv2
+ ;; Licence notice is unclear. The Web page simply say "GPL" without giving
+ ;; a version. SOME of the code files have licence notices for GPLv2+.
+ ;; The tarball contains files of the text of GPLv2 and LGPLv2.
(license license:gpl2+)))
@@ -1014,9 +1017,9 @@ use in GNOME applications, built on top of CORBA.")
(version "3.2.6")
(source (origin
(method url-fetch)
- (uri
- (let ((upstream-name "GConf"))
- (string-append "mirror://gnome/sources/" upstream-name "/"
+ (uri
+ (let ((upstream-name "GConf"))
+ (string-append "mirror://gnome/sources/" upstream-name "/"
(version-major+minor version) "/"
upstream-name "-" version ".tar.xz")))
(sha256
@@ -2308,8 +2311,7 @@ permission from user.")
(arguments
`(;; The tests want to write to $HOME/.cache/geocode-glib, which doesn't
;; work for the builder. Punt.
- #:tests? #f
- ))
+ #:tests? #f))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)
@@ -3293,7 +3295,7 @@ DAV, and others.")
(and (zero? (system* "gtkdocize"))
(zero? (system* "autoreconf" "-vif"))))))))
(home-page "https://github/hughsie/libgusb")
- (synopsis "A GLib binding for libusb1")
+ (synopsis "GLib binding for libusb1")
(description
"GUsb is a GObject wrapper for libusb1 that makes it easy to do
asynchronous control, bulk and interrupt transfers with proper cancellation
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a52106b898..1235b3185a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -87,8 +87,9 @@ arrays of data.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
- version ".tar.xz"))
+ (uri (string-append
+ "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+ version ".tar.xz"))
(sha256
(base32
"172w1bpnkn6mm1wi37n03apdbb6cdkykhzjf1vfxchcd7hhkyflp"))))
@@ -134,8 +135,8 @@ This package provides the core library and elements.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
- version ".tar.xz"))
+ (uri (string-append "http://gstreamer.freedesktop.org/src/" name "/"
+ name "-" version ".tar.xz"))
(sha256
(base32
"18sbyjcp281zb3bsqji3pglsdsxi0s6ai7rx90sx8cpflkxdqcwm"))))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 40eb8e49ed..c0c0794f4a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1108,7 +1108,7 @@ information.")
(home-page "http://www.gtk.org/gtk-doc/")
(synopsis "Documentation generator from C source code")
(description
- "GTK-Doc generates API documentation from comments added to C code. It is
+ "GTK-Doc generates API documentation from comments added to C code. It is
typically used to document the public API of GTK+ and GNOME libraries, but it
can also be used to document application code.")
(license license:gpl2+)))
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index dd0457edfe..82776e6cd3 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -796,8 +796,8 @@ key-value cache and store.")
(inputs
`(("guile" ,guile-2.0)
("python" ,python)))
- (synopsis "wisp is a whitespace to lisp syntax for Guile")
- (description "wisp is a syntax for Guile which provides a Python-like
+ (synopsis "Whitespace to lisp syntax for Guile")
+ (description "Wisp is a syntax for Guile which provides a Python-like
whitespace-significant language. It may be easier on the eyes for some
users and in some situations.")
(license gpl3+)))
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index e95f50ab6e..ff29aee489 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -182,6 +182,6 @@ Library and other user programs.")
(home-page "http://www.gnu.org/software/hurd/hurd.html")
(synopsis "GNU Hurd libraries")
(description
- "This package provides libihash, needed to build the GNU C
+ "This package provides libihash, needed to build the GNU C
Library for GNU/Hurd.")
(license gpl2+)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 39983dafb3..9252ca8504 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -572,7 +572,7 @@ slabtop, and skill.")
(arguments
'(;; util-linux is not the preferred source for some of the libraries and
;; commands, so disable them (see, e.g.,
- ;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b336339909c90559b7db40b455f172>.)
+ ;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b33633>.)
#:configure-flags '("--disable-libblkid"
"--disable-libuuid" "--disable-uuidd"
"--disable-fsck"
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 78ff83de15..726cfcd5cb 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -59,15 +59,16 @@
#:configure-flags '("--enable-ansi") ; required for use by the maxima package
#:phases (alist-cons-before
'configure 'pre-conf
- (lambda _
+ (lambda _
;; Patch bug when building readline support. This bug was
;; also observed by Debian
;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741819
(substitute* "o/gcl_readline.d"
- (("rl_attempted_completion_function = \\(CPPFunction \\*\\)rl_completion;")
+ (("rl_attempted_completion_function = \
+\\(CPPFunction \\*\\)rl_completion;")
"rl_attempted_completion_function = rl_completion;"))
- (substitute*
- (append
+ (substitute*
+ (append
'("pcl/impl/kcl/makefile.akcl"
"add-defs"
"unixport/makefile.dos"
@@ -115,8 +116,7 @@ interface to the Tk widget system.")
("libgc" ,libgc)
("libffi" ,libffi)))
(arguments
- '(#:tests? #f
- ;; During 'make check', ECL fails to initialize with "protocol not
+ '(;; During 'make check', ECL fails to initialize with "protocol not
;; supported", presumably because /etc/protocols is missing in the
;; build environment. See <http://sourceforge.net/p/ecls/bugs/300/>.
;;
@@ -139,7 +139,7 @@ interface to the Tk widget system.")
;; (string-append
;; "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
;; rearranged-phases))
- ))
+ #:tests? #f))
(home-page "http://ecls.sourceforge.net/")
(synopsis "Embeddable Common Lisp")
(description "ECL is an implementation of the Common Lisp language as
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a56b7ce966..c916fe79f1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -363,7 +363,7 @@ plotting engine by third-party applications like Octave.")
;; X11 Style with the additional restriction that derived works may only be
;; distributed as patches to the original.
(license (license:fsf-free
- "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
+ "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
(define-public hdf5
(package
@@ -406,10 +406,10 @@ extremely large and complex data collections.")
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/octave/octave-"
- version ".tar.gz"))
+ version ".tar.gz"))
(sha256
(base32
- "101jr9yck798586jz4vkjcgk36zksmxf1pxrzvipgn2xgyay0zjc"))))
+ "101jr9yck798586jz4vkjcgk36zksmxf1pxrzvipgn2xgyay0zjc"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 7a62d0bdee..0a57d26be5 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -325,7 +325,8 @@ especially over Wi-Fi, cellular, and long-distance links.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://matt.ucc.asn.au/" name "/releases/" name "-" version ".tar.bz2"))
+ "http://matt.ucc.asn.au/" name "/releases/"
+ name "-" version ".tar.bz2"))
(sha256
(base32 "1bjpbg2vi5f332q4bqxkidkjfxsqmnqvp4g1wyh8d99b8gg94nar"))))
(build-system gnu-build-system)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4d526fce0c..6a47f3b6c9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -235,8 +235,9 @@ data.")
(version "0.12")
(source (origin
(method url-fetch)
- (uri (string-append "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
- version ".tar.gz"))
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
(sha256
(base32
"0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index db5fa1e3da..1765c3a6b0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -179,7 +179,7 @@ commands would.")
("pkg-config" ,pkg-config)))
(home-page "http://i3wm.org/")
(synopsis "Improved tiling window manager")
- (description "i3 is a tiling window manager, completely written
+ (description "A tiling window manager, completely written
from scratch. i3 is primarily targeted at advanced users and
developers.")
(license bsd-3)))