summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-31 16:07:50 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:15 +0200
commita11ce10666aa19f6be3c4d261812866163ed97f2 (patch)
tree5d794ab5fe3c76ccadb29d6e51d7be2aa886879d
parent4828f040df32b2fef214034d3eddce94052f760e (diff)
downloadguix-patches-a11ce10666aa19f6be3c4d261812866163ed97f2.tar
guix-patches-a11ce10666aa19f6be3c4d261812866163ed97f2.tar.gz
gnu: ghc-uuid: Update Cabal file to r2 and relax dependencies.
* gnu/packages/haskell.scm (ghc-uuid): Update Cabal file to r2. [arguments]: Add a phase to remove test framework dependency version constraints.
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5d5815a8d4..da29e156ec 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9078,8 +9078,18 @@ functions.")
"09xhk42yhxvqmka0iqrv3338asncz8cap3j0ic0ps896f2581b6z"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=QuickCheck"
- "--allow-newer=HUnit")))
+ `(#:cabal-revision
+ ("2" "0m185q62jkfb5jsv358nxbnrkv8y8hd0qqvgvh22wvc5g9ipz0r9")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'strip-test-framework-constraints
+ (lambda _
+ (substitute* "uuid.cabal"
+ (("HUnit >= 1\\.2 && < 1\\.4") "HUnit")
+ (("QuickCheck >= 2\\.4 && < 2\\.10") "QuickCheck")
+ (("tasty >= 0\\.10 && < 0\\.12") "tasty")
+ (("tasty-hunit == 0\\.9\\.\\*") "tasty-hunit")
+ (("tasty-quickcheck == 0\\.8\\.\\*") "tasty-quickcheck")))))))
(inputs `(("ghc-cryptohash-sha1" ,ghc-cryptohash-sha1)
("ghc-cryptohash-md5" ,ghc-cryptohash-md5)
("ghc-entropy" ,ghc-entropy)