summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-27 08:21:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-27 09:58:28 +0100
commit9e7cb2f1e16fc5b70c6c0e4187443e216767323d (patch)
tree468479ed70681591b13713f66d322c16da0154b9
parentf9bd82e7a6e4e991be3f3cc6bf8bccd7feeb5241 (diff)
downloadguix-patches-9e7cb2f1e16fc5b70c6c0e4187443e216767323d.tar
guix-patches-9e7cb2f1e16fc5b70c6c0e4187443e216767323d.tar.gz
gnu: python-matplotlib: Update to 3.1.2.
* gnu/packages/python-xyz.scm (python-matplotlib): Update to 3.1.2. [arguments]: Disable test_backend_webagg and test_constrainedlayout; skip other tests tagged with "webagg".
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c89df24dd4..cb74a7ab7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3996,14 +3996,14 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(define-public python-matplotlib
(package
(name "python-matplotlib")
- (version "3.1.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "matplotlib" version))
(sha256
(base32
- "14qc109dibp32xfd9lah54djc0rc76fhbsj9cwyb328lzqmd5sqz"))))
+ "1nmshfqh7wyg15i16hx1yiylcvzkws29ivn66n3i0wyqwcpjr3lf"))))
(build-system python-build-system)
(propagated-inputs ; the following packages are all needed at run time
`(("python-cycler" ,python-cycler)
@@ -4068,8 +4068,14 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(for-each delete-file
;; test_normal_axes, test_get_tightbbox_polar
'("lib/matplotlib/tests/test_axes.py"
+ ;; We don't use the webagg backend and this test forces it.
+ "lib/matplotlib/tests/test_backend_webagg.py"
;; test_outward_ticks
"lib/matplotlib/tests/test_tightlayout.py"
+ ;; test_hidden_axes fails with minor extent
+ ;; differences, possibly due to the use of a
+ ;; different version of FreeType.
+ "lib/matplotlib/tests/test_constrainedlayout.py"
;; Fontconfig returns no fonts.
"lib/matplotlib/tests/test_font_manager.py"))
#t))
@@ -4087,7 +4093,7 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(lambda* (#:key outputs inputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests.py" "-v"
- "-m" "not network")))
+ "-m" "not network and not webagg")))
(add-before 'build 'configure-environment
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((cairo (assoc-ref inputs "cairo")))