summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-04-09 21:46:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-02 03:00:03 +0200
commit9c44af6bd67579ef0d916ecf23fe832c9d17802f (patch)
tree0ad4adeacaefb7c56d19969f09d0008e1fa8c594
parenteb305784bfa229043d53ce60c130e25b07e1447f (diff)
downloadguix-patches-9c44af6bd67579ef0d916ecf23fe832c9d17802f.tar
guix-patches-9c44af6bd67579ef0d916ecf23fe832c9d17802f.tar.gz
gnu: Replace hard-coded "CC=gcc" with CC-FOR-TARGET calls.
* gnu/packages/admin.scm (cbatticon)[arguments]<#:make-flags>: Use CC-FOR-TARGET. * gnu/packages/assembly.scm (dev86)[arguments]<#:make-flags>: Likewise. * gnu/packages/cdrom.scm (cd-discid)[arguments]<#:make-flags>: Likewise. * gnu/packages/crypto.scm (signify, keyutils, ssss, libscrypt, enchive) [arguments]<#:make-flags>: Likewise. * gnu/packages/emacs-xyz.scm (emacs-emacsql, emacs-telega)[arguments] <#:phases>: Likewise. * gnu/packages/gnupg.scm (pgpdump)[arguments]<#:make-flags>: Likewise. * gnu/packages/image-viewers.scm (feh, imv)[arguments]<#:make-flags>: Likewise. * gnu/packages/image.scm (libjxr, giflib, freeimage)[arguments] <#:make-flags>: Likewise. * gnu/packages/irc.scm (ii, sic)[arguments]<#:make-flags>: Likewise. * gnu/packages/lua.scm (make-lua-expat, make-lua-ossl, make-lua-sec) (make-lua-cqueues, make-lua-lgi, lua-resty-signal)[arguments] <#:make-flags>: Likewise. * gnu/packages/networking.scm (httping, pixiewps, sslh, nethogs, spiped) (can-utils, hcxtools, batctl)[arguments]<#:make-flags>: Likewise. * gnu/packages/pdf.scm (fbida)[arguments]<#:make-flags>: Likewise. * gnu/packages/ssh.scm (endlessh)[arguments]<#:make-flags>: Likewise. * gnu/packages/toys.scm (nyancat)[arguments]<#:make-flags>: Likewise. * gnu/packages/upnp.scm (miniupnpc)[arguments]<#:make-flags>: Likewise. * gnu/packages/xdisorg.scm (bemenu, xbanish, sxhkd, xcape, xssproxy) (xrandr-invert-colors, hsetroot, xsettingsd)[arguments]<#:make-flags>: Likewise. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/admin.scm2
-rw-r--r--gnu/packages/assembly.scm2
-rw-r--r--gnu/packages/cdrom.scm4
-rw-r--r--gnu/packages/crypto.scm13
-rw-r--r--gnu/packages/emacs-xyz.scm2
-rw-r--r--gnu/packages/gnupg.scm3
-rw-r--r--gnu/packages/image-viewers.scm9
-rw-r--r--gnu/packages/image.scm10
-rw-r--r--gnu/packages/irc.scm5
-rw-r--r--gnu/packages/lua.scm12
-rw-r--r--gnu/packages/networking.scm26
-rw-r--r--gnu/packages/pdf.scm4
-rw-r--r--gnu/packages/ssh.scm4
-rw-r--r--gnu/packages/toys.scm2
-rw-r--r--gnu/packages/upnp.scm4
-rw-r--r--gnu/packages/xdisorg.scm18
16 files changed, 62 insertions, 58 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4274a49ef0..59abaeb2eb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3062,7 +3062,7 @@ produce uniform output across heterogeneous networks.")
`(#:tests? #f ; no tests
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index dbed33bb3d..51c0572674 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -228,7 +228,7 @@ It has macro abilities and focuses on operating system portability.")
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; They use submakes wrong
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out")))
#:system "i686-linux" ; Standalone ld86 had problems otherwise
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 7ebe35e6a6..443d7455a7 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -599,9 +599,9 @@ the data.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:phases (modify-phases %standard-phases (delete 'configure))
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out")))))
(synopsis "Get CDDB discid information from an audio CD")
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 273f924962..2658c38cb4 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -214,7 +214,7 @@ communication, encryption, decryption, signatures, etc.")
;; like OpenBSD's pledge().
(arguments
`(#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -376,7 +376,7 @@ the wrong hands.")
(arguments
`(#:phases (modify-phases %standard-phases
(delete 'configure)) ; no configure script
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
"RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
(string-append "DESTDIR="
(assoc-ref %outputs "out"))
@@ -469,7 +469,7 @@ no man page, refer to the home page for usage details.")
(arguments
`(#:tests? #f ; No test suite
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configuration to be done
@@ -629,7 +629,7 @@ attacks than alternative functions such as @code{PBKDF2} or @code{bcrypt}.")
(outputs (list "out" "static"))
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
+ ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -1070,8 +1070,9 @@ cannot sign messages in OpenBSD format yet.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no check target '
- #:make-flags (list "CC=gcc" "PREFIX=$(out)")
+ `(#:tests? #f ; no check target '
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
+ "PREFIX=$(out)")
#:phases (modify-phases %standard-phases
(delete 'configure)
(add-after 'install 'post-install
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a03abd2206..dbeab25b39 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25357,7 +25357,7 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
(lambda _
(substitute* "server/Makefile"
(("CC=cc")
- "CC=gcc")
+ ,(string-append "CC=" (cc-for-target)))
(("INSTALL_PREFIX=\\$\\(HOME\\)/.telega")
(string-append "INSTALL_PREFIX=" (assoc-ref %outputs "out")
"/bin"))
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index bb611bdb89..fefa1e01f1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages xml)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -996,7 +997,7 @@ them to transform your existing public key into a secret key.")
(arguments
`(#:tests? #f ; no make check
#:configure-flags (list "--prefix=/")
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "DESTDIR=" (assoc-ref %outputs "out")))))
(inputs
`(("zlib" ,zlib)))
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index b7c1ebc829..c7dd358ad4 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -89,10 +89,11 @@
"1d13x8hmvpdc5f5rj4l29ha7iz7wvqxjlvh6il04wq8igzrj0x23"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases (delete 'configure))
+ `(#:phases (modify-phases %standard-phases (delete 'configure))
#:test-target "test"
#:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
"exif=1"
"inotify=1")))
(native-inputs
@@ -579,7 +580,7 @@ displayed in a terminal.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-after 'install 'record-absolute-file-names
@@ -593,7 +594,7 @@ displayed in a terminal.")
(string-append bin "/imv-")))
#t))))
#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "CONFIGPREFIX="
(assoc-ref %outputs "out") "/etc"))))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d0c12016ca..64863cd3b3 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -457,8 +457,8 @@ lossless JPEG manipulations such as rotation, scaling or cropping:
"libjxr-fix-typos.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- (list "CC=gcc"
+ `(#:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
;; A substitute* procedure call would be enough to add the -fPIC
;; flag if there was no file decoding error.
;; The makefile is a "Non-ISO extended-ASCII text, with CRLF line
@@ -890,7 +890,7 @@ JPEG 2000 Reference Software.")
(outputs '("bin" ; utility programs
"out")) ; library
(arguments
- '(#:make-flags (list "CC=gcc"
+ `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out"))
(string-append "BINDIR="
@@ -1114,7 +1114,7 @@ supplies a generic doubly-linked list and some string functions.")
"0cwjxjz0f4gs6igvwqg0p99mnrsrwzkal1l2n08yvz2xq9s5khki"))))))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
;; According to Fedora these files depend on private headers, but their
;; presence is required for building, so we replace them with empty files.
@@ -1138,7 +1138,7 @@ supplies a generic doubly-linked list and some string functions.")
(("-o root -g root") ""))
#t)))
#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
;; We need '-fpermissive' for Source/FreeImage.h.
;; libjxr doesn't have a pkg-config file.
(string-append "CFLAGS+=-O2 -fPIC -fvisibility=hidden -fpermissive "
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 36c4fac3c1..2cc4e5e2c2 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -31,6 +31,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
@@ -343,7 +344,7 @@ for the IRCv3 protocol.")
(arguments
`(#:tests? #f ; no tests
#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
+ ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure
@@ -367,7 +368,7 @@ for the IRCv3 protocol.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ebea69eb9a..54d2ba400d 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -215,7 +215,7 @@ some projects.")))
`(#:make-flags
(let ((out (assoc-ref %outputs "out"))
(lua-version ,(version-major+minor (package-version lua))))
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "LUA_LDIR=" out "/share/lua/" lua-version)
(string-append "LUA_CDIR=" out "/lib/lua/" lua-version)))
#:phases
@@ -356,7 +356,7 @@ directory structure and file attributes.")
`(#:make-flags
(let ((out (assoc-ref %outputs "out"))
(lua-api-version ,(version-major+minor (package-version lua))))
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
"CFLAGS='-D HAVE_SYS_SYSCTL_H=0'" ; sys/sysctl.h is deprecated
(string-append "prefix=" out)
(string-append "LUA_APIS=" lua-api-version)))
@@ -417,7 +417,7 @@ binds OpenSSL's bignum, message digest, HMAC, cipher, and CSPRNG interfaces.")
(let ((out (assoc-ref %outputs "out"))
(lua-version ,(version-major+minor (package-version lua))))
(list "linux"
- "CC=gcc"
+ ,(string-append "CC=" (cc-for-target))
"LD=gcc"
(string-append "LUAPATH=" out "/share/lua/" lua-version)
(string-append "LUACPATH=" out "/lib/lua/" lua-version)))
@@ -465,7 +465,7 @@ secure session between the peers.")
#:make-flags
(let ((out (assoc-ref %outputs "out"))
(lua-api-version ,(version-major+minor (package-version lua))))
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "LUA_APIS=" lua-api-version)))
#:phases
(modify-phases %standard-phases
@@ -657,7 +657,7 @@ describing the commented declarations and functions.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -1014,7 +1014,7 @@ on numbers.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;TODO: Run the test suite.
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 4df7b55ee7..f90894851c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1339,7 +1339,7 @@ and min/max network usage.")
"0gh17kcxxi37k65zm4gqsvbk3aw7yphcs3c02pn1c4s2y6n40axd"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'fix-ifconfig-path
@@ -1357,7 +1357,7 @@ and min/max network usage.")
test_parse_format_ipv(4(|_listen_all|_mapped_ipv6)|6)\\);")
""))
#t)))
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "prefix=" (assoc-ref %outputs "out")))
#:test-target "test"))
(inputs `(("net-tools" ,net-tools)
@@ -1639,7 +1639,7 @@ transmission protocol (SCTP) in a Go application.")
("ncurses" ,ncurses)
("openssl" ,openssl)))
(arguments
- `(#:make-flags (list "CC=gcc"
+ `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "DESTDIR=" (assoc-ref %outputs "out"))
"PREFIX=")
#:tests? #f)) ; no tests
@@ -1840,8 +1840,8 @@ allows for heavy scripting.")
"07nym6bqml0k9v29vnj003nrgnwrywgjvnljb7cdpsvnwilhbp64"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- (list "CC=gcc"
+ `(#:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -2299,7 +2299,7 @@ library remains flexible, portable, and easily embeddable.")
("pcre" ,pcre)
("tcp-wrappers" ,tcp-wrappers)))
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
(add-before 'check 'fix-tests
@@ -2321,7 +2321,7 @@ library remains flexible, portable, and easily embeddable.")
(append (find-files "." "\\.cfg")
(find-files "scripts"))))
#t)))
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
"USELIBCAP=1"
"USELIBWRAP=1"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
@@ -2384,7 +2384,7 @@ the bandwidth, loss, and other parameters.")
`(("libpcap" ,libpcap)
("ncurses" ,ncurses)))
(arguments
- `(#:make-flags `("CC=gcc"
+ `(#:make-flags `(,,(string-append "CC=" (cc-for-target))
,(string-append "PREFIX=" %output)
,(string-append "VERSION=" ,version))
#:phases
@@ -2612,11 +2612,11 @@ returns the user name and other information about the connection.")
"04rpnc53whfky7pp2m9h35gwzwn6788pnl6c1qd576mpknbqjw4d"))))
(build-system gnu-build-system)
(arguments
- '(#:test-target "test"
+ `(#:test-target "test"
#:make-flags (let* ((out (assoc-ref %outputs "out"))
(bindir (string-append out "/bin"))
(man1dir (string-append out "/share/man/man1")))
- (list "CC=gcc" ; It tries to invoke `c99`.
+ (list ,(string-append "CC=" (cc-for-target)) ; It tries to invoke `c99`.
(string-append "BINDIR=" bindir)
(string-append "MAN1DIR=" man1dir)))
#:phases
@@ -3035,7 +3035,7 @@ from user-space. It requires a kernel built with SocketCAN support.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests exist.
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out")))
#:phases
@@ -3288,7 +3288,7 @@ Ethernet and TAP interfaces is supported. Packet capture is also supported.")
("zlib" ,zlib)))
(arguments
`(#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
#:tests? #f ; no test suite
#:phases
@@ -3646,7 +3646,7 @@ written (and providing API) in C. Current implementation covers YANG 1.0 (RFC
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "PKG_CONFIG=" (assoc-ref %build-inputs "pkg-config")
"/bin/pkg-config")
- "CC=gcc")))
+ ,(string-append "CC=" (cc-for-target)))))
(home-page "https://www.open-mesh.org/projects/batman-adv/wiki/Wiki")
(synopsis "Management tool for the mesh networking BATMAN protocol")
(description "This package provides a control tool for the
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 689d03afc8..123fef92b6 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1135,7 +1135,7 @@ information for every pixel as the input.")
"0f242mix20rgsqz1llibhsz4r2pbvx6k32rmky0zjvnbaqaw1dwm"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-FHS-file-names
(lambda _
@@ -1144,7 +1144,7 @@ information for every pixel as the input.")
(("/sbin/ldconfig -p") "echo lib")) #t))
(delete 'configure))
#:tests? #f
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "prefix=" (assoc-ref %outputs "out")))))
(inputs `(("libjpeg" ,libjpeg-turbo)
("curl" ,curl)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 20db069e0f..7429d4e956 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -878,8 +878,8 @@ of existing remote shell facilities such as SSH.")
(base32 "0ziwr8j1frsp3dajr8h5glkm1dn5cci404kazz5w1jfrp0736x68"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ ,(string-append "CC=" (cc-for-target)))
#:tests? #f ; no test target
#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index f88ea68436..bbd5753841 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -219,7 +219,7 @@ and various scenery elements.")
"1mg8nm5xzcq1xr8cvx24ym2vmafkw53rijllwcdm9miiz0p5ky9k"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("CC=gcc")
+ `(#:make-flags '(,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 9b586c1cf2..358514f9d0 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -61,11 +61,11 @@
;; The build system does not use a configure script but depends on
;; `make'. Hence we should pass parameters to `make' instead and remove
;; the configure phase.
- '(#:make-flags
+ `(#:make-flags
(list
(string-append "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
(string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc"
+ ,(string-append "CC=" (cc-for-target))
;; Allow executables to find libminiupnpc.so.
(string-append "LDFLAGS=-Wl,-rpath="
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 418fe73fdc..15c5377a3d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -269,8 +269,8 @@ used to further tweak the behaviour of the different profiles.")
(base32 "1fjcs9d3533ay3nz79cx3c0lmy2chgragr2lhsy0xl2ckr0iins0"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
- #:make-flags (list "CC=gcc"
+ `(#:tests? #f
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
"CFLAGS=-O2 -fPIC"
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib")
@@ -892,7 +892,7 @@ to find buttons, etc, on the screen to click on.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
+ #:make-flags (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases (modify-phases %standard-phases
(delete 'configure)))) ; no configure script
@@ -1071,7 +1071,7 @@ Guile will work for XBindKeys.")
`(#:phases (modify-phases %standard-phases (delete 'configure))
#:tests? #f ; no check target
#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" %output)
;; Keep the documentation where the build system installs LICENSE.
(string-append "DOCPREFIX=" %output
@@ -1184,7 +1184,7 @@ within a single process.")
#:phases (modify-phases %standard-phases (delete 'configure))
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"MANDIR=/share/man/man1"
- "CC=gcc")))
+ ,(string-append "CC=" (cc-for-target)))))
(inputs
`(("libxtst" ,libxtst)
("libx11" ,libx11)))
@@ -1553,7 +1553,7 @@ demos. It also acts as a nice screen locker.")
(arguments `(#:make-flags `("bindir=/bin"
"man1dir=/share/man/man1"
,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ ,,(string-append "CC=" (cc-for-target)))
#:phases (modify-phases %standard-phases
(delete 'configure)
(delete 'check))))
@@ -2102,7 +2102,7 @@ to automatically turn it on on login.")
"1br3x9vr6xm4ika06n8cfxx1b3wdchdqvyzjl4y1chmivrml8x9h"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc")
+ `(#:make-flags (list ,(string-append "CC=" (cc-for-target)))
#:tests? #f ; there are none
#:phases
(modify-phases %standard-phases
@@ -2407,7 +2407,7 @@ Xwrits hides itself until you should take another break.")
(arguments
`(#:scons ,scons-python2
#:scons-flags
- (list "CC=gcc")
+ (list ,(string-append "CC=" (cc-for-target)))
#:phases
(modify-phases %standard-phases
(add-before 'build 'patch-sconstruct
@@ -2762,7 +2762,7 @@ and execute @file{.desktop} files of the Application type.")
`(#:tests? #f
#:make-flags
(list
- "CC=gcc"
+ ,(string-append "CC=" (cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases