summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-03 17:31:27 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-11-18 11:29:25 +0100
commit9869bb1296830a58609cdfca016f297aa97e1145 (patch)
treec26e013d945841306cd62758a2cf5d2b92a5a5f7
parent82af2c2f0f9eaaa1408c4e36d8a4273bf6f05ea1 (diff)
downloadguix-patches-9869bb1296830a58609cdfca016f297aa97e1145.tar
guix-patches-9869bb1296830a58609cdfca016f297aa97e1145.tar.gz
gnu: Add bitshuffle.
* gnu/packages/compression.scm (bitshuffle): New variable.
-rw-r--r--gnu/packages/compression.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index c06c3c52e9..de6d5b9093 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
+;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
#:use-module (gnu packages file)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1026,6 +1028,37 @@ well as bzip2.")
(license (list license:gpl3+
license:public-domain)))) ; most files in lzma/
+(define-public bitshuffle
+ (package
+ (name "bitshuffle")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bitshuffle" version))
+ (sha256
+ (base32
+ "01vcjrvsxjvv47y5hf9rps69zwv0vwd4ydhhms2jfs4rpcnlak6v"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'make-required-dir
+ (lambda _
+ (mkdir-p "bitshuffle/plugin"))))))
+ (inputs
+ `(("numpy" ,python-numpy)
+ ("h5py" ,python-h5py)
+ ("hdf5" ,hdf5)))
+ (native-inputs
+ `(("cython" ,python-cython)))
+ (home-page "https://github.com/kiyo-masui/bitshuffle")
+ (synopsis "Filter for improving compression of typed binary data")
+ (description "Bitshuffle is an algorithm that rearranges typed, binary data
+for improving compression, as well as a python/C package that implements this
+algorithm within the Numpy framework.")
+ (license license:expat)))
+
(define-public snappy
(package
(name "snappy")