summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-20 16:52:16 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-21 00:10:03 +0200
commit980c33bd3f16e44a123ef21408a56e59ebb76373 (patch)
tree6602c463998d0617fff66d812c0fe4276512a1b3
parent5ae0d2c24737572ba3e0619a0176a07758078e1d (diff)
downloadguix-patches-980c33bd3f16e44a123ef21408a56e59ebb76373.tar
guix-patches-980c33bd3f16e44a123ef21408a56e59ebb76373.tar.gz
gnu: ocaml-merlin: Inherit from ‘ocaml-dot-merlin-reader’.
* gnu/packages/ocaml.scm (ocaml-merlin): Inherit from ‘ocaml-dot-merlin-reader’, thus also updating it to 4.2-411. [version, source, build-system, home-page]: Remove. [arguments]<#:phases>: Use custom test phase. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 58b34d4293..21d16a46a1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4566,21 +4566,16 @@ format}. @code{craml} is released as a single binary (called @code{craml}).")
(define-public ocaml-merlin
(package
+ (inherit ocaml-dot-merlin-reader)
(name "ocaml-merlin")
- (version "3.4.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ocaml/merlin")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0i2nwkdh6cfzmnsdsr8aw86vs8j1k5jkjzrs61b9384wnffdbbmj"))))
- (build-system dune-build-system)
- (arguments '(#:package "merlin"
- #:test-target "tests"))
+ (arguments
+ '(#:package "merlin"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dune" "runtest" "-p" "merlin,dot-merlin-reader")))))))
(inputs
`(("ocaml-yojson" ,ocaml-yojson)
("ocaml-csexp" ,ocaml-csexp)
@@ -4589,7 +4584,6 @@ format}. @code{craml} is released as a single binary (called @code{craml}).")
`(("ocaml-dot-merlin-reader" ,ocaml-dot-merlin-reader) ; required for tests
("ocaml-mdx" ,ocaml-mdx)
("jq" ,jq)))
- (home-page "https://ocaml.github.io/merlin/")
(synopsis "Context sensitive completion for OCaml in Vim and Emacs")
(description "Merlin is an editor service that provides modern IDE
features for OCaml. Emacs and Vim support is provided out-of-the-box.