summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-18 21:49:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-19 09:53:04 +0100
commit9800f7d9e81f259c9041fffb5dc14930bff3379d (patch)
tree58de83b7cb41648189b231477fe681f3d42a51a7
parent4376166b03bdafebb16fbec3577ca16bccd48cd5 (diff)
downloadguix-patches-9800f7d9e81f259c9041fffb5dc14930bff3379d.tar
guix-patches-9800f7d9e81f259c9041fffb5dc14930bff3379d.tar.gz
gnu: r-bookdown: Update to 0.7.
* gnu/packages/bioinformatics.scm (r-bookdown): Update to 0.7. [propagated-inputs]: Add r-tinytex.
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2c8dc8f399..354a809c44 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6672,27 +6672,28 @@ also known as views, in a controlled vocabulary.")
(define-public r-bookdown
(package
- (name "r-bookdown")
- (version "0.6")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "bookdown" version))
- (sha256
- (base32
- "1pxxln42kvzl38fjprg6hcnyh1kij75fpj70vwp5hp5il813aszc"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-htmltools" ,r-htmltools)
- ("r-knitr" ,r-knitr)
- ("r-rmarkdown" ,r-rmarkdown)
- ("r-yaml" ,r-yaml)
- ("r-xfun" ,r-xfun)
- ("ghc-pandoc" ,ghc-pandoc)))
- (home-page "https://github.com/rstudio/bookdown")
- (synopsis "Authoring books and technical documents with R markdown")
- (description "This package provides output formats and utilities for
+ (name "r-bookdown")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bookdown" version))
+ (sha256
+ (base32
+ "1b3fw1f41zph5yw3kynb47aijq53vhaa6mnnvxly72zamyzdf95q"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-yaml" ,r-yaml)
+ ("r-xfun" ,r-xfun)
+ ("ghc-pandoc" ,ghc-pandoc)))
+ (home-page "https://github.com/rstudio/bookdown")
+ (synopsis "Authoring books and technical documents with R markdown")
+ (description "This package provides output formats and utilities for
authoring books and technical documents with R Markdown.")
- (license license:gpl3)))
+ (license license:gpl3)))
(define-public r-biocstyle
(package