summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-25 13:28:38 +0200
committerGuix Patches Tester <>2020-05-25 12:33:09 +0100
commit96f8d36162717ca21038f6eaa661e6d8514d1fee (patch)
tree9b722977aad64011f212f411c9439103bee1409d
parent7e0c5f2b05405de7db9ec7d1137252a8955685e0 (diff)
downloadguix-patches-96f8d36162717ca21038f6eaa661e6d8514d1fee.tar
guix-patches-96f8d36162717ca21038f6eaa661e6d8514d1fee.tar.gz
gnu: Add python-questionary
gnu/packages/python-xyz.scm (python-questionary): New variable.
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d48c42275..6230b26038 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9405,6 +9405,39 @@ be set via config files and/or environment variables.")
@code{ArgumentParser} object.")
(license license:asl2.0)))
+(define-public python-questionary
+ (package
+ (name "python-questionary")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "questionary" version))
+ (sha256
+ (base32
+ "09n737qmvzbibl8hmbd5zfg1502fd9n0r8qjzz1y0vy8nqv1xr7n"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-prompt-toolkit" ,python-prompt-toolkit)))
+ (native-inputs
+ `(("python-coveralls" ,python-coveralls)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-pycodestyle"
+ ,python-pytest-pycodestyle)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "py.test"))))))
+ (home-page "https://github.com/tmbo/questionary")
+ (synopsis
+ "Pretty command line user prompts")
+ (description
+ "Questionary helps make the input prompts easy to read and answer for the user
+using multi-select lists, confirmations, free text prompts, completion, etc.")
+ (license license:expat)))
+
(define-public python-contextlib2
(package
(name "python-contextlib2")