summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-19 17:50:37 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 02:13:33 +0200
commit96dce8c7fe0d86a7997a771e60b735789f97bc19 (patch)
tree4a908ee731a853b96eeb5471d0537ae7cb9b41f3
parent97d3a9f781ac4e436cad4a7c1a59de8f48baec0c (diff)
downloadguix-patches-96dce8c7fe0d86a7997a771e60b735789f97bc19.tar
guix-patches-96dce8c7fe0d86a7997a771e60b735789f97bc19.tar.gz
gnu: ocaml4.07-pcre: Remove package.
* gnu/packages/ocaml.scm (ocaml4.07-pcre): Remove package. It has been superseded by ‘ocaml-pcre’. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 549009eb09..22767ee2a2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3118,36 +3118,6 @@ offered by the Perl language.")
;; With static linking exception
(license license:lgpl2.1+)))
-(define-public ocaml4.07-pcre
- (package
- (name "ocaml4.07-pcre")
- (version "7.4.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mmottl/pcre-ocaml")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11sd8g668h48790lamz0riw9jgnfkaif5qdfa0akcndwa6aj07jf"))))
- (build-system dune-build-system)
- (arguments
- `(#:test-target "."
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (native-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("pcre:bin" ,pcre "bin")))
- (propagated-inputs `(("pcre" ,pcre)))
- (home-page "https://mmottl.github.io/pcre-ocaml")
- (synopsis "Bindings to the Perl Compatibility Regular Expressions library")
- (description "Pcre-ocaml offers library functions for string pattern
-matching and substitution, similar to the functionality offered by the Perl
-language.")
- (license license:lgpl2.1+))); with the OCaml link exception
-
(define-public ocaml-expect
(package
(name "ocaml-expect")