summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-02 09:51:37 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-02 09:54:16 +0300
commit95c9785b428bd332644de201c7f9ac7e8f4cd72f (patch)
treef31cbce0e6fd743562aa69d5f15477c00e2562c7
parent86f86cffd822afc012e308490e9931a66ce924aa (diff)
downloadguix-patches-95c9785b428bd332644de201c7f9ac7e8f4cd72f.tar
guix-patches-95c9785b428bd332644de201c7f9ac7e8f4cd72f.tar.gz
gnu: Add emacs-jenkinsfile-mode.
* gnu/packages/emacs-xyz.scm (emacs-jenkinsfile-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6b42544396..a90d789d7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12783,6 +12783,30 @@ Groovy source files, REPL integration with run-groovy and Grails project
navigation with the grails mode.")
(license license:gpl3+)))
+(define-public emacs-jenkinsfile-mode
+ (let ((commit "00d259ff9b870d234540e00e1d7c83cccdb063b8")
+ (revision "1"))
+ (package
+ (name "emacs-jenkinsfile-mode")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john2x/jenkinsfile-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0srf6xdjnrd4v4ks9pal7i48wmkcl4q5ry7d0yzfx1c9pz2qg9zx"))))
+ (propagated-inputs
+ `(("emacs-groovy-modes" ,emacs-groovy-modes)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/john2x/jenkinsfile-mode/")
+ (synopsis "Emacs major-mode for editing Jenkinsfile")
+ (description "This package provides a @code{jenkinsfile-mode} derived
+from @code{groovy-mode} for editing Jenkins declarative pipeline files.")
+ (license license:gpl3+))))
+
(define-public emacs-org-tree-slide
(let ((commit "036a36eec1cf712d3db155572aed325daa372eb5")
(revision "2"))