summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-04 23:18:26 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-09 13:04:17 +0100
commit931eaeaad9ef59cad651b6bd548a6151ac53d1d3 (patch)
treef91c85e1bdd565e6afd353c044c352ed6032ebcb
parent9fde877856d82ee4c040fd904c4eb5378acea5ee (diff)
downloadguix-patches-931eaeaad9ef59cad651b6bd548a6151ac53d1d3.tar
guix-patches-931eaeaad9ef59cad651b6bd548a6151ac53d1d3.tar.gz
gnu: python-pyqt-5.5: Use non-inherited "configure" phase.
This allows passing different options for 5.5 than for the main version (which is currently 5.6). * gnu/packages.qt.scm (python-pyqt-5.5, python2-pyqt-5.5)[arguments]: Copy from (python-pyqt)[arguments].
-rw-r--r--gnu/packages/qt.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index fc4700e2d4..aaa7e1cff7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1054,6 +1054,36 @@ contain over 620 classes.")
(base32
"056qmkv02wdcfblqdaxiswrgn4wa88sz22i1x58dpb1iniavplfd"))
(patches (search-patches "pyqt-configure.patch"))))
+ (arguments
+ `(#:modules ((srfi srfi-1)
+ ,@%gnu-build-system-modules)
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (sip (string-append out "/share/sip"))
+ (plugins (string-append out "/plugins"))
+ (designer (string-append plugins "/designer"))
+ (qml (string-append plugins "/PyQt5"))
+ (python (assoc-ref inputs "python"))
+ (python-version
+ (last (string-split python #\-)))
+ (python-major+minor
+ (string-join
+ (take (string-split python-version #\.) 2)
+ "."))
+ (lib (string-append out "/lib/python"
+ python-major+minor
+ "/site-packages")))
+ (zero? (system* "python" "configure.py"
+ "--confirm-license"
+ "--bindir" bin
+ "--destdir" lib
+ "--designer-plugindir" designer
+ "--qml-plugindir" qml
+ "--sipdir" sip))))))))
(native-inputs
`(("python-sip" ,python-sip)
("qt" ,qt)))))