summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2020-10-15 22:23:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-19 21:20:33 +0100
commit92797b3b8888140086c6ab5bb30b2d4570484ce3 (patch)
treee454194a8bd3a9c89002fb818befdd83f6c738ef
parentb04198a1477f9d685d674a1dcc81b79b530fc409 (diff)
downloadguix-patches-92797b3b8888140086c6ab5bb30b2d4570484ce3.tar
guix-patches-92797b3b8888140086c6ab5bb30b2d4570484ce3.tar.gz
gnu: emacs-request: Update to latest commit.
* gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 25 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4ded928c73..e551fb71dc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7044,29 +7044,33 @@ parallel.")
(license license:gpl3+)))
(define-public emacs-request
- (package
- (name "emacs-request")
- (version "0.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tkf/emacs-request")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #f)) ; requires network access.
- (propagated-inputs
- `(("emacs-deferred" ,emacs-deferred)))
- (home-page "https://github.com/tkf/emacs-request")
- (synopsis "Package for speaking HTTP in Emacs Lisp")
- (description "This package provides a HTTP request library with multiple
+ ;; We prefer a more recent commit that has support for auth-source,
+ ;; which makes authentication more convenient for users and maintainers.
+ (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+ (revision "0"))
+ (package
+ (name "emacs-request")
+ (version (git-version "0.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tkf/emacs-request")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #f)) ; requires network access.
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)))
+ (home-page "https://github.com/tkf/emacs-request")
+ (synopsis "Package for speaking HTTP in Emacs Lisp")
+ (description "This package provides a HTTP request library with multiple
backends. It supports url.el which is shipped with Emacs and the curl command
line program.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-rudel
(package