summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 11:27:48 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:52 +0200
commit92607967c2dcad9d60bcbd0be593cf2dfc24aa36 (patch)
tree5b12adb95951418f55840c17b52d1e9355533f8a
parent60c964ab7593fb5bf9a123f7be975211641435ab (diff)
downloadguix-patches-92607967c2dcad9d60bcbd0be593cf2dfc24aa36.tar
guix-patches-92607967c2dcad9d60bcbd0be593cf2dfc24aa36.tar.gz
gnu: python-pytest-django: Update to 3.10.0.
* gnu/packages/django.scm (python-pytest-django): Update to 3.10.0. [arguments]: Remove #:tests?. Override check phase. [native-inputs]: Add PYTHON-PYTEST-XDIST.
-rw-r--r--gnu/packages/django.scm35
1 files changed, 26 insertions, 9 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c086cab3f3..b1de294e61 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -309,26 +309,43 @@ size and quality.")
(define-public python-pytest-django
(package
(name "python-pytest-django")
- (version "3.1.2")
+ (version "3.10.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "pytest-django" version))
(sha256
(base32
- "02932m2sr8x22m4az8syr8g835g4ak77varrnw71n6xakmdcr303"))))
+ "19nvqsb7b9kz3ikpb50m8ppf7mfhzrapdxsqd5hhd1pdfz8dprjd"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; FIXME: How to run tests?
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-setuppy
- (lambda _
- (substitute* "setup.py"
- (("setuptools_scm==1.11.1") "setuptools_scm"))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (if tests?
+ (begin
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PYTHONPATH"
+ (string-append ".:" ;for pytest_django_test
+ (getenv "PYTHONPATH")))
+ (setenv "PYTEST_DJANGO_TEST_RUNNER" "pytest")
+ (setenv "DJANGO_SETTINGS_MODULE"
+ "pytest_django_test.settings_sqlite_file")
+ (invoke "pytest" "-vv" "-k"
+ ;; FIXME: these tests fail to locate Django templates ...
+ (string-append "not test_django_not_loaded_without_settings"
+ " and not test_settings"
+ ;; ... and this does not discover
+ ;; 'pytest_django_test'.
+ " and not test_urls_cache_is_cleared")))
+ (format #t "test suite not run~%"))
#t)))))
(native-inputs
`(("python-django" ,python-django)
- ("python-setuptools-scm" ,python-setuptools-scm)))
+ ("python-setuptools-scm" ,python-setuptools-scm)
+
+ ;; For tests.
+ ("python-pytest-xdist" ,python-pytest-xdist)))
(propagated-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://pytest-django.readthedocs.org/")