summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:00 +0200
commit914d2c2142eb22a0219cf09475ea7207808ded6a (patch)
treeb59065cd22986fba6e48449630c9a93736cb1441
parent2c67e1cfbf5dc4c528f9ddb5dce843bd8326cdab (diff)
downloadguix-patches-914d2c2142eb22a0219cf09475ea7207808ded6a.tar
guix-patches-914d2c2142eb22a0219cf09475ea7207808ded6a.tar.gz
gnu: agda: Use G-expressions.
* gnu/packages/agda.scm (agda)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/agda.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 706360c94f..87e787b72d 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -71,22 +71,22 @@
ghc-uri-encode
ghc-zlib))
(arguments
- `(#:modules ((guix build haskell-build-system)
- (guix build utils)
- (srfi srfi-26)
- (ice-9 match))
- #:phases
- (modify-phases %standard-phases
- ;; This allows us to call the 'agda' binary before installing.
- (add-after 'unpack 'set-ld-library-path
- (lambda _
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
- (add-after 'compile 'agda-compile
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (agda-compiler (string-append out "/bin/agda")))
- (for-each (cut invoke agda-compiler <>)
- (find-files (string-append out "/share") "\\.agda$"))))))))
+ (list #:modules `((guix build haskell-build-system)
+ (guix build utils)
+ (srfi srfi-26)
+ (ice-9 match))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; This allows us to call the 'agda' binary before installing.
+ (add-after 'unpack 'set-ld-library-path
+ (lambda _
+ (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
+ (add-after 'compile 'agda-compile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((agda-compiler (string-append #$output "/bin/agda")))
+ (for-each (cut invoke agda-compiler <>)
+ (find-files (string-append #$output "/share")
+ "\\.agda$"))))))))
(home-page "https://wiki.portal.chalmers.se/agda/")
(synopsis
"Dependently typed functional programming language and proof assistant")