summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-06-08 22:58:37 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-14 09:55:37 +0200
commit901ceafadd05349d6dc254541c50da0bff4d2885 (patch)
tree59637db5613a6ac8c68428d308835278eaeba70e
parent26ac7d024636bd495a2039d5cfd9777eebd4214e (diff)
downloadguix-patches-901ceafadd05349d6dc254541c50da0bff4d2885.tar
guix-patches-901ceafadd05349d6dc254541c50da0bff4d2885.tar.gz
gnu: Add cl-glfw3.
* gnu/packages/lisp-xyz.scm (sbcl-cl-glfw3, ecl-cl-glfw3, cl-glfw3): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 873944ba9d..f3b13f00e1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17290,3 +17290,46 @@ and even allows the generic visualisation of graphs in this format.")
(define-public cl-flow
(sbcl-package->cl-source-package sbcl-flow))
+
+(define-public sbcl-cl-glfw3
+ (let ((commit "32c3f34d592d55ee7ce932ed85804c1a9c4158c6")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-glfw3")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AlexCharlton/cl-glfw3")
+ (commit commit)))
+ (file-name (git-file-name "cl-glfw3" version))
+ (sha256
+ (base32 "1wzr43nckdx4rlgxzhm1r4kfc264q969mc43y0js9ramh7l8gba5"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-glfw-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "glfw-bindings.lisp"
+ (("libglfw.so.3" all)
+ (string-append (assoc-ref inputs "glfw") "/lib/" all))))))))
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cffi" ,sbcl-cffi)
+ ("cl-opengl" ,sbcl-cl-opengl)
+ ("glfw" ,glfw)
+ ("trivial-main-thread" ,sbcl-trivial-main-thread)))
+ (home-page "https://github.com/AlexCharlton/cl-glfw3")
+ (synopsis "Common Lisp bindings to GLFW version 3.x")
+ (description
+ "This package provides a Common Lisp bindings to @code{glfw}, an OpenGL
+application development library.")
+ (license license:bsd-2))))
+
+(define-public ecl-cl-glfw3
+ (sbcl-package->ecl-package sbcl-cl-glfw3))
+
+(define-public cl-glfw3
+ (sbcl-package->cl-source-package sbcl-cl-glfw3))