summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-20 23:31:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:21 -0500
commit8f78f61c029bb45c39fa782f8ac2c6962e44cdab (patch)
tree2932aea668f9b45d599ba10e581f519487a1edd0
parentb8324050ada78a6da96717aee972ceddaa77e528 (diff)
downloadguix-patches-8f78f61c029bb45c39fa782f8ac2c6962e44cdab.tar
guix-patches-8f78f61c029bb45c39fa782f8ac2c6962e44cdab.tar.gz
gnu: nss: Update to 3.71.
This is made in an attempt to get rid of non-deterministic test failures, namely: [ FAILED ] TlsConnectDatagram13.AeadLimit * gnu/packages/nss.scm (nss): Update comment about nss-certs. Update to 3.71. [phases]{check}: Update faketime date. [inputs]{sqlite}: Use the regular version. * gnu/packages/certs.scm (nss-certs): Inherit version and source from nss.
-rw-r--r--gnu/packages/certs.scm14
-rw-r--r--gnu/packages/nss.scm14
2 files changed, 8 insertions, 20 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 39c3ebd128..f5ab726e0b 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -128,18 +128,8 @@ that was originally contributed to Debian.")
(define-public nss-certs
(package
(name "nss-certs")
- (version "3.67")
- (source (origin
- (method url-fetch)
- (uri (let ((version-with-underscores
- (string-join (string-split version #\.) "_")))
- (string-append
- "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
- "releases/NSS_" version-with-underscores "_RTM/src/"
- "nss-" version ".tar.gz")))
- (sha256
- (base32
- "0zyfi27lbdz1bmk9dmsivcya4phx25rzlxqcnjab69yd928rlm7n"))))
+ (version (package-version nss))
+ (source (package-source nss))
(build-system gnu-build-system)
(outputs '("out"))
(native-inputs
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index dcb5f0303c..fcd6938022 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -94,12 +94,12 @@ platform-neutral API for system level and libc-like functions. It is used
in the Mozilla clients.")
(license license:mpl2.0)))
-;;; Note: When updating, also update the nss-certs package, which cannot
-;;; inherit from here.
+;;; Note: When updating, verify that the nss-certs package still builds fine
+;;; as it inherits its source from the nss package.
(define-public nss
(package
(name "nss")
- (version "3.67")
+ (version "3.71")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -110,7 +110,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "0zyfi27lbdz1bmk9dmsivcya4phx25rzlxqcnjab69yd928rlm7n"))
+ "0ly2l3dv6z5hlxs72h5x6796ni3x1bq60saavaf42ddgv4ax7b4r"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"
@@ -163,7 +163,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2021-06-01" "./nss/tests/all.sh"))
+ (invoke "faketime" "2021-09-30" "./nss/tests/all.sh"))
(format #t "test suite not run~%"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
@@ -187,9 +187,7 @@ in the Mozilla clients.")
(copy-recursively (string-append obj "/bin") bin)
(copy-recursively (string-append obj "/lib") lib)))))))
(inputs
- `(;; XXX: Build with SQLite 3.33 to work around
- ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1714874
- ("sqlite" ,sqlite-3.33)
+ `(("sqlite" ,sqlite)
("zlib" ,zlib)))
(propagated-inputs
`(("nspr" ,nspr))) ;required by nss.pc.