summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-11 23:42:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-11 23:42:40 -0400
commit8e0a8819b7836e844c1bca500a0c4d03a97cf3a0 (patch)
treec56b97f1242d1a5550fc5d31a86d65dd5135de6f
parent62b44b0b4e69b7fd1b9c1994d0e58af1214c820d (diff)
downloadguix-patches-8e0a8819b7836e844c1bca500a0c4d03a97cf3a0.tar
guix-patches-8e0a8819b7836e844c1bca500a0c4d03a97cf3a0.tar.gz
gnu: python-keras: Skip a flaky test.
* gnu/packages/machine-learning.scm (python-keras) [phases]{check}: Also skip the test_stateful_metrics test.
-rw-r--r--gnu/packages/machine-learning.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a2b5283900..1a17c73eea 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2561,9 +2561,14 @@ with image data, text data, and sequence data.")
"-p" "no:pep8"
;; FIXME: python-build-system lacks PARALLEL-TESTS?
"-n" (number->string (parallel-job-count))
- ;; The following test fail only in the build container;
- ;; skip it.
- "-k" "not test_selu")))))))
+ "-k"
+ (string-append
+ ;; The following test fails only in the build
+ ;; container; skip it.
+ "not test_selu "
+ ;; The following test was found flaky and removed in
+ ;; recent versions.
+ "and not test_stateful_metrics"))))))))
(propagated-inputs
`(("python-h5py" ,python-h5py)
("python-keras-applications" ,python-keras-applications)