summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-11 17:00:57 +0100
committerLeo Famulari <leo@famulari.name>2017-01-11 13:09:21 -0500
commit8d67610bdc542b92c2b500e36e4e66c090dadede (patch)
tree27dd5eb7f0183da12f76023a4371779c7407ae24
parentdc673fa1131fb5d1e5ca29acb4a693cfb906986f (diff)
downloadguix-patches-8d67610bdc542b92c2b500e36e4e66c090dadede.tar
guix-patches-8d67610bdc542b92c2b500e36e4e66c090dadede.tar.gz
gnu: Add python2-cheetah
* gnu/packages/python.scm (python2-cheetah): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c15a12f9be..727e1bff26 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12331,3 +12331,47 @@ possible on all supported Python versions.")
(define-public python2-xopen
(package-with-python2 python-xopen))
+
+(define-public python2-cheetah
+ (package
+ (name "python2-cheetah")
+ (version "2.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Cheetah" version))
+ (sha256
+ (base32
+ "0l5mm4lnysjkzpjr95q5ydm9xc8bv43fxmr79ypybrf1y0lq4c5y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (propagated-inputs
+ `(("python2-markdown" ,python2-markdown)))
+ (home-page "https://pythonhosted.org/Cheetah/")
+ (synopsis "Template engine")
+ (description "Cheetah is a text-based template engine and Python code
+generator.
+
+Cheetah can be used as a standalone templating utility or referenced as
+a library from other Python applications. It has many potential uses,
+but web developers looking for a viable alternative to ASP, JSP, PHP and
+PSP are expected to be its principle user group.
+
+Features:
+@enumerate
+@item Generates HTML, SGML, XML, SQL, Postscript, form email, LaTeX, or any other
+ text-based format.
+@item Cleanly separates content, graphic design, and program code.
+@item Blends the power and flexibility of Python with a simple template language
+ that non-programmers can understand.
+@item Gives template writers full access to any Python data structure, module,
+ function, object, or method in their templates.
+@item Makes code reuse easy by providing an object-orientated interface to
+ templates that is accessible from Python code or other Cheetah templates.
+ One template can subclass another and selectively reimplement sections of it.
+@item Provides a simple, yet powerful, caching mechanism that can dramatically
+ improve the performance of a dynamic website.
+@item Compiles templates into optimized, yet readable, Python code.
+@end enumerate")
+ (license (license:x11-style "file://LICENSE"))))