summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-24 23:48:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-25 14:08:31 +0200
commit8b1fd3cafd9c3040d098ff538a233bf7dc43b397 (patch)
treeb1448e75faf7c35c895990edb69acc0e19f8eaef
parent46b0136e09b14d35bf8ce160cbb9bd93b49e525a (diff)
downloadguix-patches-8b1fd3cafd9c3040d098ff538a233bf7dc43b397.tar
guix-patches-8b1fd3cafd9c3040d098ff538a233bf7dc43b397.tar.gz
gnu: bioperl-minimal: Don't use unstable tarball.
* gnu/packages/bioinformatics.scm (bioperl-minimal)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 511146bb6e..beb442ebe0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -983,16 +983,17 @@ e.g. microbiome samples, genomes, metagenomes.")
(version "1.7.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/bioperl/bioperl-live/"
- "archive/release-"
- (string-map (lambda (c)
- (if (char=? c #\.)
- #\- c)) version)
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bioperl/bioperl-live")
+ (commit (string-append "release-"
+ (string-map (lambda (c)
+ (if (char=? c #\.)
+ #\- c)) version)))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "12phgpxwgkqflkwfb9dcqg7a31dpjlfhar8wcgv0aj5ln4akfz06"))))
+ "0wl8yvzcls59pwwk6m8ahy87pwg6nnibzy5cldbvmcwg2x2w7783"))))
(build-system perl-build-system)
(arguments
`(#:phases