summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-06 13:55:55 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:18 +0200
commit892d5546472e214849fced1a5ab23a7afab53e94 (patch)
tree6d5bb7cbd6c7eda9a17d3e768ec3cf3f334cc9f2
parent8574e6c704f3e89e243b36793fedbfa0ea3bade0 (diff)
downloadguix-patches-892d5546472e214849fced1a5ab23a7afab53e94.tar
guix-patches-892d5546472e214849fced1a5ab23a7afab53e94.tar.gz
gnu: ghc-cgi: Adjust dependency constraints.
* gnu/packages/haskell.scm (ghc-cgi)[arguments]: Remove "--allow-newer" configure flag; add a phase that patches the Cabal file to allow newer versions of exceptions, time, doctest, and QuickCheck.
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 45a43d6272..ba8491429b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1093,7 +1093,19 @@ tool lex or flex for C/C++.")
"1hbpplss1m4rdpm4ibip6fpimlhssqa14fl338kl2jbc463i64cj"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=QuickCheck")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "cgi.cabal"
+ (("exceptions < 0\\.9")
+ "exceptions < 0.11")
+ (("time >= 1\\.5 && < 1\\.7")
+ "time >= 1.5 && < 1.9")
+ (("doctest >= 0\\.8 && < 0\\.12")
+ "doctest >= 0.8 && < 0.17")
+ (("QuickCheck >= 2\\.8\\.1 && < 2\\.10")
+ "QuickCheck >= 2.8.1 && < 2.12")))))))
(inputs
`(("ghc-parsec" ,ghc-parsec)
("ghc-exceptions" ,ghc-exceptions)