summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-10 19:43:05 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 00:21:11 +0200
commit88f976d1604e229c47ecfc16e0c95a36817d5043 (patch)
treec127406086e1abc6ec2ac345d36a247d501fc18e
parentd8d4b81147df59542385a79191eb51e3568ae309 (diff)
downloadguix-patches-88f976d1604e229c47ecfc16e0c95a36817d5043.tar
guix-patches-88f976d1604e229c47ecfc16e0c95a36817d5043.tar.gz
gnu: qtwayland: Fix build with GCC 11.
* gnu/packages/patches/qtwayland-gcc-11.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (qtwayland)[source](patches): New field.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qtwayland-gcc-11.patch18
-rw-r--r--gnu/packages/qt.scm1
3 files changed, 20 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 247b9ec34f..1bd791fb0c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1750,6 +1750,7 @@ dist_patch_DATA = \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
+ %D%/packages/patches/qtwayland-gcc-11.patch \
%D%/packages/patches/qtwebkit-pbutils-include.patch \
%D%/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch \
%D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
diff --git a/gnu/packages/patches/qtwayland-gcc-11.patch b/gnu/packages/patches/qtwayland-gcc-11.patch
new file mode 100644
index 0000000000..06983ff2f3
--- /dev/null
+++ b/gnu/packages/patches/qtwayland-gcc-11.patch
@@ -0,0 +1,18 @@
+Add missing import for newer libstdc++.
+
+Taken from upstream:
+
+ https://github.com/qt/qtwayland/commit/1aa6ec2c778504d96543f6cdc2b9199a7b066fc1
+
+diff --git a/tests/auto/client/shared/corecompositor.cpp b/tests/auto/client/shared/corecompositor.cpp
+index 5c6c83baa..fa9b7662a 100644
+--- a/tests/auto/client/shared/corecompositor.cpp
++++ b/tests/auto/client/shared/corecompositor.cpp
+@@ -27,6 +27,7 @@
+ ****************************************************************************/
+
+ #include "corecompositor.h"
++#include <thread>
+
+ namespace MockCompositor {
+
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7d0f1b4971..be6665a57f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1456,6 +1456,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
+ (patches (search-patches "qtwayland-gcc-11.patch"))
(sha256
(base32
"1ddfx4nak16xx0zh1kl836zxvpbixmmjyplsmfmg65pqkwi34dqr"))))