summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-01 13:45:38 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-01 14:18:38 +0200
commit87390c155eb6ab0c6ed037104eeae3ba7925316a (patch)
tree9661535c0468a618482ad8cdcbb0936b6445c851
parent6e3fdbbe264b2a233f32f521e2547e4b6175578b (diff)
downloadguix-patches-87390c155eb6ab0c6ed037104eeae3ba7925316a.tar
guix-patches-87390c155eb6ab0c6ed037104eeae3ba7925316a.tar.gz
gnu: libssh: Update to 0.6.5.
* gnu/packages/ssh.scm (libssh): Update to 0.6.5. [source]: Remove 'patches'. [inputs]: Use LIBGCRYPT instead of LIBGCRYPT-1.5.
-rw-r--r--gnu/packages/ssh.scm24
1 files changed, 6 insertions, 18 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index f9a3a42e14..2e74fbda43 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -43,24 +43,15 @@
(define-public libssh
(package
(name "libssh")
- (version "0.6.3")
+ (version "0.6.5")
(source (origin
(method url-fetch)
- (uri (string-append "https://red.libssh.org/attachments/download/87/libssh-"
- version ".tar.xz"))
+ (uri (string-append
+ "https://red.libssh.org/attachments/download/121/libssh-"
+ version ".tar.xz"))
(sha256
(base32
- "1jyaj9h1iglvn02hrvcchbx8ycjpj8b91h8mi459k7q5jp2xgd9b"))
- (patches
- ;; Apply the patch as discussed at
- ;; <http://lists.gnu.org/archive/html/guix-devel/2014-10/msg00180.html>.
- (list (origin
- (uri
- "http://git.libssh.org/projects/libssh.git/patch/?id=a033b93c616f4a81afc3fc6a017396d507d96c19")
- (method url-fetch)
- (sha256
- (base32
- "16fdkjcnhc6j7qxz9575fzr9044927ws5259yh0xb9yv1q14j0vh")))))))
+ "0b6wyx6bwbb8jpn8x4rhlrdiqwqrwrs0mxjmrnqykm9kw1ijgm8g"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DWITH_GCRYPT=ON")
@@ -68,10 +59,7 @@
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))
(inputs `(("zlib" ,zlib)
- ;; Link against an older gcrypt, because libssh tries to access
- ;; fields of 'gcry_thread_cbs' that are now private:
- ;; src/threads.c:72:26: error: 'struct gcry_thread_cbs' has no member named 'mutex_init'
- ("libgcrypt", libgcrypt-1.5)))
+ ("libgcrypt", libgcrypt)))
(synopsis "SSH client library")
(description
"libssh is a C library implementing the SSHv2 and SSHv1 protocol for