summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 15:12:27 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:14 -0400
commit860fc8b895a64278547053ad08c56110f59cec3c (patch)
tree591b5d1ec0266e8c0f34af5240760c6e1bca7fd1
parent6c9a9e823e2e8bde3d967b24e9b0bc1df27c86e7 (diff)
downloadguix-patches-860fc8b895a64278547053ad08c56110f59cec3c.tar
guix-patches-860fc8b895a64278547053ad08c56110f59cec3c.tar.gz
gnu: ruby-cucumber-messages: Update to 21.0.1.
* gnu/packages/ruby.scm (ruby-cucumber-messages): Update to 21.0.1. [source]: Adjust to upstream URI change and use url-fetch. [phases]: Delete patch-protobuf.rb and compile phases. Move check phase after install phase, and augment GEM_PATH in check phase. [propagated-inputs]: Delete field. [native-inputs]: Add ruby-cucumber-compatibility-kit-bootstrap. [home-page]: Update URL.
-rw-r--r--gnu/packages/ruby.scm48
1 files changed, 19 insertions, 29 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d6bd371bfb..de9583aa6b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7992,40 +7992,30 @@ Cucumber implementation's support for the Cucumber Messages protocol.")
(define-public ruby-cucumber-messages
(package
(name "ruby-cucumber-messages")
- (version "12.2.0")
+ (version "21.0.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cucumber/messages-ruby")
- (commit "12cd07eac87bce7843fd1bb0bf64bc4da09f097c")))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (rubygems-uri "cucumber-messages" version))
(sha256
(base32
- "16wwqfpsq7crvxc3q08lphgyh12cl2d83p1c79p312q4jmy9cn5a"))))
+ "0482a63y7my0arn2bv208g401dq8525f0gwhnwaa11mhv6ph0q5i"))))
(build-system ruby-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-protobuf.rb
- (lambda _
- (substitute* "rake/protobuf.rb"
- (("load 'protobuf/tasks/compile.rake'")
- "require 'protobuf/tasks'"))
- #t))
- (add-before 'build 'compile
- (lambda _
- (substitute* "Makefile"
- (("bundle exec ") "")
- (("include default.mk.*" all)
- (string-append "#" all)))
- (invoke "make")))
- (replace 'check
- (lambda _
- (invoke "rspec"))))))
- (propagated-inputs
- `(("ruby-protobuf" ,ruby-protobuf-cucumber)))
- (native-inputs
- (list ruby-rspec))
- (home-page "https://github.com/cucumber/messages-ruby")
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; The test suite requires the gem to be installed, so move it
+ ;; after the install phase.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (setenv "GEM_PATH" (string-append
+ (getenv "GEM_PATH") ":"
+ #$output "/lib/ruby/vendor_ruby"))
+ (when tests?
+ (invoke "rspec")))))))
+ (native-inputs
+ (list ruby-cucumber-compatibility-kit-bootstrap ruby-rspec))
+ (home-page "https://github.com/cucumber/messages/")
(synopsis "Cucumber Messages for Ruby (Protocol Buffers)")
(description "Cucumber Messages for Ruby is a library which allows
serialization and deserialization of the protocol buffer messages used in