summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-04-14 23:21:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-04-14 23:23:18 +0300
commit802c94034cf8900987855c205fcb0ae37af985c7 (patch)
tree2f5b7f354ff12b27070cb78acc4e85fc28c4a4b6
parent6083372f61b3a23077bbbe294f552b9664fac658 (diff)
downloadguix-patches-802c94034cf8900987855c205fcb0ae37af985c7.tar
guix-patches-802c94034cf8900987855c205fcb0ae37af985c7.tar.gz
gnu: python-pywavelets: Remove cythonized files.
* gnu/packages/python-xyz.scm (python-pywavelets)[source]: Add snippet to remove cythonized files. [native-inputs]: Add python-cython.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36e4fe5898..d70d8cc270 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7671,7 +7671,17 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
(uri (pypi-uri "PyWavelets" version))
(sha256
(base32
- "13csbr6ls9q9ww53z2xwwsj0hpsz88rj2iwp623h0kmv8yq6kgbc"))))
+ "13csbr6ls9q9ww53z2xwwsj0hpsz88rj2iwp623h0kmv8yq6kgbc"))
+ (snippet
+ #~(begin
+ (use-modules ((guix build utils)))
+ (for-each delete-file
+ (list
+ "pywt/_extensions/_cwt.c"
+ "pywt/_extensions/_dwt.c"
+ "pywt/_extensions/_pywt.c"
+ "pywt/_extensions/_pywt.h"
+ "pywt/_extensions/_swt.c"))))))
(build-system python-build-system)
(arguments
'(#:modules ((ice-9 ftw)
@@ -7689,7 +7699,8 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
(with-directory-excursion (string-append cwd "/build/" libdir)
(invoke "pytest" "-vv"))))))))
(native-inputs
- (list python-matplotlib ;for tests
+ (list python-cython
+ python-matplotlib ;for tests
python-pytest))
(propagated-inputs
(list python-numpy))