summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-05-08 18:57:20 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-05-08 23:19:09 +0530
commit7fc5ca1d1885fa4103698b3f0b6251018a11cfbb (patch)
treeac0f540086a18f565cff6c2dcf6bba9280e92295
parent52a468e842b25f5b6403ca89d9c00b01311246d6 (diff)
downloadguix-patches-7fc5ca1d1885fa4103698b3f0b6251018a11cfbb.tar
guix-patches-7fc5ca1d1885fa4103698b3f0b6251018a11cfbb.tar.gz
gnu: Add emacs-cwl-mode.
* gnu/packages/emacs-xyz.scm (emacs-cwl-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e554c6b10a..c9b7dff293 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27906,3 +27906,26 @@ files, providing syntax highlighting and indentation rules.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+
+(define-public emacs-cwl-mode
+ (package
+ (name "emacs-cwl-mode")
+ (version "0.2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tom-tan/cwl-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x9rvyhgy7ijq2r9pin94jz7nisrw6z91jch7d27lkhrmyb1rwk3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-yaml-mode" ,emacs-yaml-mode)))
+ (home-page "https://github.com/tom-tan/cwl-mode")
+ (synopsis "Emacs mode for @acronym{CWL, Common Workflow Language} files")
+ (description "This packages provides a major mode for editing
+@acronym{CWL, Common Workflow Language} files.")
+ (license license:gpl3+)))