summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-27 10:01:44 -0500
committerMark H Weaver <mhw@netris.org>2014-12-27 11:18:29 -0500
commit7f9b77dc465f35a3689036e12d0bf85ed7d81f52 (patch)
tree2383a6bac4f34cdd903650f8508c78f8b68adcb9
parent85f41902219122824db5393dec85b1ff5f40cf29 (diff)
downloadguix-patches-7f9b77dc465f35a3689036e12d0bf85ed7d81f52.tar
guix-patches-7f9b77dc465f35a3689036e12d0bf85ed7d81f52.tar.gz
gnu: vtk: Fix build with mesa-10.
* gnu/packages/patches/vtk-mesa-10.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/vtk.scm (vtk): Add patch. Add glu to inputs.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/vtk-mesa-10.patch36
-rw-r--r--gnu/packages/vtk.scm8
3 files changed, 43 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 5acc6f4413..fea7447964 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -458,6 +458,7 @@ dist_patch_DATA = \
gnu/packages/patches/udev-gir-libtool.patch \
gnu/packages/patches/util-linux-perl.patch \
gnu/packages/patches/vpnc-script.patch \
+ gnu/packages/patches/vtk-mesa-10.patch \
gnu/packages/patches/w3m-fix-compile.patch \
gnu/packages/patches/wmctrl-64-fix.patch \
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
diff --git a/gnu/packages/patches/vtk-mesa-10.patch b/gnu/packages/patches/vtk-mesa-10.patch
new file mode 100644
index 0000000000..bc60af68c4
--- /dev/null
+++ b/gnu/packages/patches/vtk-mesa-10.patch
@@ -0,0 +1,36 @@
+Fix build against new mesa. See:
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=83631
+ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765938
+
+Description: fixes FTBFS against new libjpeg-turbo
+Author: Ondřej Surý <ondrej@debian.org>
+Bug-Debian: https://bugs.debian.org/765938
+Reviewed-By: Anton Gladky <gladk@debian.org>
+Last-Update: 2014-10-22
+
+Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
+===================================================================
+--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkOpenGL.h
++++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
+@@ -20,6 +20,7 @@
+
+ // To prevent gl.h to include glext.h provided by the system
+ #define GL_GLEXT_LEGACY
++#define GLX_GLEXT_LEGACY
+ #if defined(__APPLE__) && (defined(VTK_USE_CARBON) || defined(VTK_USE_COCOA))
+ # include <OpenGL/gl.h> // Include OpenGL API.
+ #else
+Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
+===================================================================
+--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
++++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
+@@ -27,7 +27,7 @@
+
+ // define GLX_GLXEXT_LEGACY to prevent glx.h to include glxext.h provided by
+ // the system
+-//#define GLX_GLXEXT_LEGACY
++#define GLX_GLXEXT_LEGACY
+ #include "GL/glx.h"
+
+ #include "vtkgl.h"
diff --git a/gnu/packages/vtk.scm b/gnu/packages/vtk.scm
index 3d30279683..17312103dd 100644
--- a/gnu/packages/vtk.scm
+++ b/gnu/packages/vtk.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gl))
@@ -36,7 +38,8 @@
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))))
+ "0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))
+ (patches (list (search-patch "vtk-mesa-10.patch")))))
(build-system cmake-build-system)
(arguments
;; Build without '-g' to save space.
@@ -46,7 +49,8 @@
`(("libXt" ,libxt)
("xproto" ,xproto)
("libX11" ,libx11)
- ("mesa" ,mesa)))
+ ("mesa" ,mesa)
+ ("glu" ,glu)))
(home-page "http://www.vtk.org/")
(synopsis "Libraries for 3D computer graphics")
(description