summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-08-16 16:18:09 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-01 23:08:37 +0200
commit7e7b27d9060420a5dad8e082d71f46c0fea4a7d9 (patch)
treed70f2d7f11be1b672caacfb6e2ec262799ddd11a
parent44fd0994a0eb06a2f2b639f529ca8f64969c8736 (diff)
downloadguix-patches-7e7b27d9060420a5dad8e082d71f46c0fea4a7d9.tar
guix-patches-7e7b27d9060420a5dad8e082d71f46c0fea4a7d9.tar.gz
gnu: add python-appdirs.
* gnu/packages/python.scm (python-appdirs, python2-appdirs): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 75f285fbed..19dcf5af79 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4652,3 +4652,31 @@ or create documents in LilyPond format. A command line program ly is also
provided that can be used to do various manipulations with LilyPond files.")
(home-page "https://pypi.python.org/pypi/python-ly")
(license gpl2+)))
+
+(define-public python-appdirs
+ (package
+ (name "python-appdirs")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/a/appdirs/appdirs-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1iddva7v3fq0aqzsahkazxr7vpw28mqcrsy818z4wyiqnkplbhlg"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://github.com/ActiveState/appdirs")
+ (synopsis
+ "Determine platform-specific dirs, e.g. a \"user data dir\"")
+ (description
+ "This module provides a portable way of finding out where user data
+should be stored on various operating systems.")
+ (license license:expat)))
+
+(define-public python2-appdirs
+ (package-with-python2 python-appdirs))