summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-28 21:02:57 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-28 21:30:28 +0200
commit7dbd5339d7e9c572afa0aa051dd304abe702cb7d (patch)
tree070c22a43f119b8cfcd575ff685360a572a18786
parentcb11325a1870c61143929acb9d32953bacd2b265 (diff)
downloadguix-patches-7dbd5339d7e9c572afa0aa051dd304abe702cb7d.tar
guix-patches-7dbd5339d7e9c572afa0aa051dd304abe702cb7d.tar.gz
gnu: python-slugify: Honor #:tests?.
* gnu/packages/python-web.scm (python-slugify)[arguments]: Honor #:tests?
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fcca8697a8..62de043e70 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4594,8 +4594,9 @@ Python.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "test.py"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "test.py")))))))
(build-system python-build-system)
(home-page "https://github.com/un33k/python-slugify")
(synopsis "Python Slugify application that handles Unicode")