summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-26 22:43:41 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-26 22:43:41 +0100
commit7bf569186c12cc9d344905ef673fecaa92a6c023 (patch)
treecaaae91d7d94f9bc4dbf17ad98969a15dbcacad7
parent47a9cb950a181e7efa8af06f1c679ed0390a9164 (diff)
downloadguix-patches-7bf569186c12cc9d344905ef673fecaa92a6c023.tar
guix-patches-7bf569186c12cc9d344905ef673fecaa92a6c023.tar.gz
gnu: Add GNU cflow.
* gnu/packages/cflow.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/cflow.scm51
2 files changed, 52 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2380e75fc6..c785014451 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ MODULES = \
gnu/packages/bison.scm \
gnu/packages/bootstrap.scm \
gnu/packages/cdrom.scm \
+ gnu/packages/cflow.scm \
gnu/packages/check.scm \
gnu/packages/cmake.scm \
gnu/packages/compression.scm \
diff --git a/gnu/packages/cflow.scm b/gnu/packages/cflow.scm
new file mode 100644
index 0000000000..bb000ddc59
--- /dev/null
+++ b/gnu/packages/cflow.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cflow)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages emacs))
+
+(define-public cflow
+ (package
+ (name "cflow")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/cflow/cflow-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1jkbq97ajcf834z68hbn3xfhiz921zhn39gklml1racf0kb3jzh3"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/cflow/")
+ (synopsis "A tool to analyze the control flow of C programs")
+ (description
+ "GNU cflow analyzes a collection of C source files and prints a
+graph, charting control flow within the program.
+
+GNU cflow is able to produce both direct and inverted flowgraphs
+for C sources. Optionally a cross-reference listing can be
+generated. Two output formats are implemented: POSIX and GNU
+(extended).
+
+The package also provides Emacs major mode for examining the
+produced flowcharts in Emacs.")
+ (license gpl3+)))