summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-03-05 01:39:44 +0530
committerGuix Patches Tester <>2020-03-05 20:01:53 +0000
commit79be28d0abaaae2265e2861cd3f2d1f73d1dad15 (patch)
tree7f44891a5f8dd0d482c1b5962a225abef5832e54
parent5d0f33c2ab9aa0cdc51a35525e895a603eac78ea (diff)
downloadguix-patches-79be28d0abaaae2265e2861cd3f2d1f73d1dad15.tar
guix-patches-79be28d0abaaae2265e2861cd3f2d1f73d1dad15.tar.gz
gnu: avr-gcc: Update to 7.4.0.
* gnu/packages/avr.scm (avr-gcc-7, avr-toolchain-7): New variables. (avr-gcc-4.9, avr-gcc-5, avr-toolchain-4.9, avr-toolchain-5): Delete variables. (avr-libc)[arguments]: Remove custom fix-cpath phase.
-rw-r--r--gnu/packages/avr.scm32
1 files changed, 6 insertions, 26 deletions
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 608e487b93..8a964b9b17 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,8 +41,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-4.9
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-4.9 #:xbinutils avr-binutils)))
+(define-public avr-gcc-7
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -78,18 +79,9 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc" ,gcc-5)
+ `(("gcc" ,gcc-7)
,@(package-native-inputs xgcc))))))
-(define-public avr-gcc-5
- (package
- (inherit avr-gcc-4.9)
- (version (package-version gcc-5))
- (source (origin
- (inherit (package-source gcc-5))
- (patches (append (origin-patches (package-source gcc-5))
- (search-patches "gcc-cross-environment-variables.patch")))))))
-
(define (avr-libc avr-gcc)
(package
(name "avr-libc")
@@ -104,18 +96,7 @@
(build-system gnu-build-system)
(arguments
'(#:out-of-source? #t
- #:configure-flags '("--host=avr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'unpack 'fix-cpath
- (lambda _
- ;; C_INCLUDE_PATH and CPATH pose issues for cross-building,
- ;; leading to failures when building avr-libc on 64-bit systems.
- ;; Simply unsetting them allows the build to succeed because it
- ;; doesn't try to use any of the native system's headers.
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPATH")
- #t)))))
+ #:configure-flags '("--host=avr")))
(native-inputs `(("avr-binutils" ,avr-binutils)
("avr-gcc" ,avr-gcc)))
(home-page "https://www.nongnu.org/avr-libc/")
@@ -149,8 +130,7 @@ C++.")
(home-page (package-home-page avr-libc))
(license (package-license avr-gcc)))))
-(define-public avr-toolchain-4.9 (avr-toolchain avr-gcc-4.9))
-(define-public avr-toolchain-5 (avr-toolchain avr-gcc-5))
+(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
(define-public microscheme
(package