summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-20 01:43:05 -0400
committerMark H Weaver <mhw@netris.org>2014-08-20 01:43:05 -0400
commit785c33e3af9107118e57ba9efb39152f1b467a6f (patch)
treeba45c12ba17dd0a3fdbf872497893eb3429ab1ec
parenta23276cd8b7cabb8cba12b9bc260eb7925ce4ee2 (diff)
downloadguix-patches-785c33e3af9107118e57ba9efb39152f1b467a6f.tar
guix-patches-785c33e3af9107118e57ba9efb39152f1b467a6f.tar.gz
gnu: libffi: Update to 3.1.
* gnu/packages/patches/libffi-mips-n32-fix.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/libffi.scm (libffi): Update to 3.1. Remove patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/libffi.scm7
-rw-r--r--gnu/packages/patches/libffi-mips-n32-fix.patch21
3 files changed, 3 insertions, 26 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 3f1c3c6ee5..3da1c75b97 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -328,7 +328,6 @@ dist_patch_DATA = \
gnu/packages/patches/kmod-module-directory.patch \
gnu/packages/patches/libbonobo-activation-test-race.patch \
gnu/packages/patches/libevent-dns-tests.patch \
- gnu/packages/patches/libffi-mips-n32-fix.patch \
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
gnu/packages/patches/libmad-mips-newgcc.patch \
gnu/packages/patches/libtheora-config-guess.patch \
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index c5e265087e..33e10d6fc2 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -29,11 +29,11 @@
;; available in $includedir where some users expect them.
'(lambda* (#:key outputs #:allow-other-keys)
(define out (assoc-ref outputs "out"))
- (symlink (string-append out "/lib/libffi-3.0.13/include")
+ (symlink (string-append out "/lib/libffi-3.1/include")
(string-append out "/include")))))
(package
(name "libffi")
- (version "3.0.13")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri
@@ -41,8 +41,7 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "077ibkf84bvcd6rw1m6jb107br63i2pp301rkmsbgg6300adxp8x"))
- (patches (list (search-patch "libffi-mips-n32-fix.patch")))))
+ "1sznmrhcswwbyqla9y2ximlkzbxks59wjfs3lh7qf8ayranyxzlp"))))
(build-system gnu-build-system)
(arguments `(#:phases (alist-cons-after 'install 'post-install
,post-install-phase
diff --git a/gnu/packages/patches/libffi-mips-n32-fix.patch b/gnu/packages/patches/libffi-mips-n32-fix.patch
deleted file mode 100644
index 87ec48f883..0000000000
--- a/gnu/packages/patches/libffi-mips-n32-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix handling of uint32_t arguments on the MIPS N32 ABI.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- libffi/src/mips/ffi.c.orig 2013-03-16 07:19:39.000000000 -0400
-+++ libffi/src/mips/ffi.c 2013-10-22 01:11:03.111985247 -0400
-@@ -170,7 +170,14 @@
- break;
-
- case FFI_TYPE_UINT32:
-+#ifdef FFI_MIPS_N32
-+ /* The N32 ABI requires that 32-bit integers
-+ be sign-extended to 64-bits, regardless of
-+ whether they are signed or unsigned. */
-+ *(ffi_arg *)argp = *(SINT32 *)(* p_argv);
-+#else
- *(ffi_arg *)argp = *(UINT32 *)(* p_argv);
-+#endif
- break;
-
- /* This can only happen with 64bit slots. */