summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:00:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:39 +0200
commit768fea0fd4b77d765472576f13ccf17e25182271 (patch)
tree6e90782d7a8328df12c10ae2e73d0047a7fb0642
parent5c44505b6db1fc8c88e0e6aca4d332e46745b588 (diff)
downloadguix-patches-768fea0fd4b77d765472576f13ccf17e25182271.tar
guix-patches-768fea0fd4b77d765472576f13ccf17e25182271.tar.gz
gnu: python-gridmap: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-gridmap)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 014026d06e..ae3d8427ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4456,13 +4456,13 @@ memoizing PEG/Packrat parser in Python.")
(version "0.13.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/pygridtools/gridmap/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pygridtools/gridmap.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1gzjg2k6f14i1msm2b0ax8d9ds1hvk6qd5nlaivg8m4cxqp4cp1x"))))
+ (base32 "1478lbwsr1w24cii2x01m2910fvh8r43ghnb78nc972a96hqiknm"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; FIXME: Requires python-cherrypy.