summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:43 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:49 +0200
commit768732eb2f193868f6114e9f4f6cc0b1a8c84411 (patch)
treef9213923c0b0d44d251d56addf37723a5babedf4
parent25644879c1c94ff65636dcf498db36ed8409439c (diff)
downloadguix-patches-768732eb2f193868f6114e9f4f6cc0b1a8c84411.tar
guix-patches-768732eb2f193868f6114e9f4f6cc0b1a8c84411.tar.gz
gnu: Add python-pytest-xvfb.
* gnu/packages/python-check.scm (python-pytest-xvfb): New variable.
-rw-r--r--gnu/packages/python-check.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 15dbe65473..f0b454eec9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -886,6 +887,42 @@ for the @code{pytest} framework.")
rounds that are calibrated to the chosen timer.")
(license license:bsd-2)))
+(define-public python-pytest-xvfb
+ (package
+ (name "python-pytest-xvfb")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-xvfb" version))
+ (sha256
+ (base32 "1kyq5rg27dsnj7dc6x9y7r8vwf8rc88y2ppnnw6r96alw0nn9fn4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'prepare-tests
+ (lambda _
+ (system "Xvfb &")
+ (setenv "DISPLAY" ":0")
+
+ ;; This test is meant to run on Windows.
+ (delete-file "tests/test_xvfb_windows.py")
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("xorg-server" ,xorg-server-for-tests)))
+ (propagated-inputs
+ `(("python-pyvirtualdisplay"
+ ,python-pyvirtualdisplay)))
+ (home-page "https://github.com/The-Compiler/pytest-xvfb")
+ (synopsis "Pytest plugin to run Xvfb for tests")
+ (description
+ "This package provides a Pytest plugin to run Xvfb for tests.")
+ (license license:expat)))
+
(define-public python-pytest-services
(package
(name "python-pytest-services")