summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZelphir Kaltstahl <zelphirkaltstahl@posteo.de>2021-04-10 22:13:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-10 12:09:40 +0200
commit767c3df815ce086987e2a293415c8dece3fabc78 (patch)
tree17e3ce0c217336f3bb64963d1e6db45dd2ad67d1
parentce3d05cc08c01351756ab5d5b7f25cfe0295c230 (diff)
downloadguix-patches-767c3df815ce086987e2a293415c8dece3fabc78.tar
guix-patches-767c3df815ce086987e2a293415c8dece3fabc78.tar.gz
gnu: Add guile-fslib.
* gnu/packages/guile-xyz.scm (guile-fslib): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f908fb8a3b..67c6a7f125 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4665,3 +4666,27 @@ properties inspired by ghc-quickcheck. You can use it to express properties,
which functions should satisfy, as Scheme code and then check whether they hold
in a large number of randomly generated test cases.")
(license license:gpl3+)))
+
+(define-public guile-fslib
+ (package
+ (name "guile-fslib")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/ZelphirKaltstahl/guile-fslib/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "118d84p443w7hrslv8hjyhgws631ia08mggiyklkmk0b9plfdsvz"))))
+ (build-system guile-build-system)
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://notabug.org/ZelphirKaltstahl/guile-fslib")
+ (synopsis "Helper functions for working with locations in file systems")
+ (description
+ "This package contains helper functions for working with file system
+locations.")
+ (license license:agpl3+)))